|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28403 ORA dll make apache child process crash and restart Apache
Submitted: 2004-05-14 17:43 UTC Modified: 2005-07-09 01:00 UTC
Avg. Score:4.8 ± 0.6
Reproduced:15 of 15 (100.0%)
Same Version:4 (26.7%)
Same OS:9 (60.0%)
From: scouture at novo dot ca Assigned:
Status: No Feedback Package: OCI8 related
PHP Version: 4.3.7 OS: win 2003 server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
13 + 18 = ?
Subscribe to this entry?

 [2004-05-14 17:43 UTC] scouture at novo dot ca
I know that I've got a 4.3.3 version of PHP but this issue (child process exited with status ...) do not seems to have been adressed. 

RAM 2.49 Go
Xeon(TM) CPU 2.80 GHz

APACHE 2.0.47

In Apache error.log
[Wed May 12 14:09:59 2004] [notice] Parent: child process exited with status 3221226324 -- Restarting.


Erreur de file d'attente de rapport : application d?faillante Apache.exe, 
version, module d?faillant oranl9.dll, version, adresse de d?faillance 0x0001232b.

Pour plus d'informations, consultez le centre Aide et support ? 

0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 41 70 61   ure  Apa
0018: 63 68 65 2e 65 78 65 20   che.exe 
0020: 32 2e 30 2e 34 37 2e 30
0028: 20 69 6e 20 6f 72 61 6e    in oran
0030: 6c 39 2e 64 6c 6c 20 30   l9.dll 0
0038: 2e 30 2e 30 2e 30 20 61   .0.0.0 a
0040: 74 20 6f 66 66 73 65 74   t offset
0048: 20 30 30 30 31 32 33 32    0001232
0050: 62                        b       

0000: 6c707041 74616369 206e6f69 6c696146
0010: 20657275 61704120 2e656863 20657865
0020: 2e302e32 302e3734 206e6920 6e61726f
0030: 642e396c 30206c6c 302e302e 6120302e
0040: 666f2074 74657366 30303020 32333231
0050: 62

Expected result:
Apache not crashing


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-14 18:23 UTC]
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

Also, upgrade to latest version..
 [2004-05-23 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2004-06-30 20:41 UTC] scouture at novo dot ca
Ok, it is a long process for us just upgrade our php version. We have to pass by a dev environment before going to prod so we have pass to PHP 4.3.7 in prod recently. And since that the PHP team have annonce the release of 4.3.8. :o)

But we still have the problem. Same error that the one list bellow. 

I can add that the server is a multiprocessor server (4 procs). We have a lot of hits by minutes. The error occurs every 5-10 minutes so kind of frequently. Apache and php are call via C# services and soap implementation. We do not seem to have this problem with a low volume environment (in our labs). The requests we pass via apache/phh are very simple (insert into... where, update ... where) nothing consumming.

Please tell me if you need something more. Thanks for your help.

 [2004-07-01 09:24 UTC]
Sounds like a threading issue to me... and you're asking for those by running apache 2 on windows (where the default processing model for apache is threaded). It sounds like either the oracle extension or oracle libraries are not threadsafe. I'll suspend this until you can come up with a clear script to reproduce this as there is no other way to find what this problem might be.
 [2004-07-02 11:18 UTC] Lukas dot Theiler at ch dot ibm dot com
Referring to Bug #28983 (now bogus:-) ) - we reprouced that error using 
- different versions of oracle clients (8.1.7, 9i, 10g, accessing through different methods)
- different versions of php (4.2.x, 4.3.x 5.x)
- different versions of apache (1.3x, IBM http server, apache)

- Stable on Linux single and multiprocessor systems
- Stable on Windows *single* processor systems
- Crash on Windows *multi* processor systems

How to replicate the error? 
a) use the OCIlogon script from Bug #28983 
b) use a loadtest tool, e.g. OpenSTA and run 5 concurrent users calling the above php script.

You'd see the crash within a few secs :-)

I agree with derik, that it is probably related to oci.dll or php_oci8.dll.

/cheers Lukas
 [2004-07-15 10:42 UTC] Lukas dot Theiler at ch dot ibm dot com
Running longer tests, even single-cpu systems fail. (after 7hours 1st, 1h34 2nd crash, 6h23 3rd crash...)
 [2004-07-22 11:14 UTC] alain dot bertrand at psi dot ch
I'm having the same bug with PHP 4.3.4, Oracle 9i and Windows 2003 Server. So it's maybe linked to 9i and windows 2003. Will check out with 10i hoping it will fix this bug. High rated for me.

Alain Bertrand
 [2004-07-22 11:15 UTC] alain dot bertrand at psi dot ch
BTW running on a dual CPU here, and it crash every 5 minutes :-(
 [2004-07-22 21:42 UTC]
There is a possilbe fix in the cvs version of both php4 and 5. Could you please check it out by downloading it from ?

 [2004-09-02 15:03 UTC] scouture at novo dot ca
Note that I have also experimented this issue with MySql on a Xeon dual procs server.

I have find that if I run php with the .dll like 
LoadModule php4_module "d:/Program Files/php/sapi/php4apache2.dll", I get the bug.

If I run php with Action application/x-httpd-php "/php/php.exe", I don't seem to have it, so far....
 [2004-11-08 12:41 UTC]
Reproduced on 1.3 -> not apache related, some Oracle threading issue.
 [2005-06-30 19:27 UTC] scouture at novo dot ca
No more problem when running PHP with the exe instead of the .dll
 [2005-06-30 19:30 UTC]
Please try using this CVS snapshot:
For Windows:

Anyone care to test the PHP 5.1 beta to see if it is running any better?
 [2005-07-01 01:05 UTC] stuff at mikepalmer dot net
is there any chance of this being fixed in the 4.3 branch also? We have some other issues using 5.x but can't use the 4.3.x dll on multi processor win32 machines either. Gets a couple hits and dies. Single processor win32 system is just fine.
 [2005-07-01 02:38 UTC]
If we can get some feedback about how well it's working in PHP 5, then we can evaluate the possibility of back-porting the changes so that they can be used with PHP 4.4
 [2005-07-09 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2006-04-12 12:04 UTC] jarismar_silva at adplabs dot com dot br
I'm having this same problem when upgrading to oracle 10g and php5.1.2(Jan 11 2006 16:35:21).
I'm using 'extension=php_oci8.dll'.

Windows give this error signature :
szAppName : Apache.exe
szAppVer :
szModName : OraClient10.Dll
szModVer :
offset : 000ab9d3

The machine is for development purposes and is a:
Windows XP Professional SP2
P4 CPU 2.8GHz 2Gb Ram

I tried to download your patch, but your link to is broken.
 [2006-04-12 13:09 UTC] jarismar_silva at adplabs dot com dot br
I have replaced the php_oci8.dll with another found at (labeled with #7) and now everthing works fine.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 21 22:01:32 2024 UTC