php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28374 sometime httpd daemon stacks
Submitted: 2004-05-12 18:41 UTC Modified: 2004-05-12 18:50 UTC
From: a-noda at jaist dot ac dot jp Assigned:
Status: Closed Package: PostgreSQL related
PHP Version: 4.3.6 OS: FreeBSD 4.9
Private report: No CVE-ID:
 [2004-05-12 18:41 UTC] a-noda at jaist dot ac dot jp
Description:
------------
I'm using mod_php4 fllowing environment
FreeBSD 4.9 apache+mod_ssl-1.3.29+2.8.16_1 mod_php4-4.3.6 postgresql-7.4.2

(all these programs compiled with gcc version 2.95.4 20020320 [FreeBSD]  -march=i686 -mpentiumpro -O2 -pipe)

sometime httpd daemon stacks with CPU usage almost 100%

I pached fllowing patch to /usr/ports/lang/php4/work/php-4.3.6/ext/pgsql/pgsql.c
It may be good. At least in my environment the process stack never comes since this patch was patched

225c225
<       while (i && (message[i] == '\r' || message[i] == '\n')) {
---
>       while (i>0 && (message[i] == '\r' || message[i] == '\n')) {


Reproduce code:
---------------
no reproduce code .
It often happen after .php files are updated with "cvs up"
 

Expected result:
----------------
none

Actual result:
--------------
none

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-12 18:50 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 15:01:54 2014 UTC