php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28354 sybase_free_result crash
Submitted: 2004-05-10 22:28 UTC Modified: 2004-05-21 22:34 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: alahaye at fmlogistic dot com Assigned:
Status: Closed Package: Sybase-ct (ctlib) related
PHP Version: 4.3.6 OS: Linux RadHat 7
Private report: No CVE-ID: None
 [2004-05-10 22:28 UTC] alahaye at fmlogistic dot com
Description:
------------
When using sybase_free_result, apache Segmentation fault.
PB doesn't exist with PHP 4.3.4.

Reproduce code:
---------------
<?
$query = "EXEC MyPROC";

$id = sybase_connect(SERVER,LOGIN,PASSWORD);
sybase_select_db(BASE,$id);
$result = sybase_query($query,$id);
 While ($row = sybase_fetch_row ($result))
  {
         print $row[0]."<BR>";
  }
sybase_free_result($result);
sybase_close($id);
?>

Expected result:
----------------
result of stored procedure


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-10 22:55 UTC] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
 [2004-05-11 14:01 UTC] sergio dot zia at saipm dot com
I am encountering exactly the same problem :-(

Linux RedHat AS 2.1
PHP 4.3.6
 [2004-05-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2004-05-19 13:55 UTC] alahaye at fmlogistic dot com
Here the backtrace

(gdb) bt
#0  0x40ba7df0 in chunk_free (ar_ptr=0x40c50f00, p=0x8436518) at malloc.c:3131
#1  0x40ba7d59 in __libc_free (mem=0x84368e8) at malloc.c:3054
#2  0x0816ed49 in shutdown_memory_manager (silent=0, clean_cache=0) at /users/sources/php/php-4.3.6/Zend/zend_alloc.c:492
#3  0x08154c44 in php_request_shutdown (dummy=0x0) at /users/sources/php/php-4.3.6/main/main.c:1003
#4  0x0819870d in main (argc=2, argv=0xbffff70c) at /users/sources/php/php-4.3.6/sapi/cli/php_cli.c:873
#5  0x40b44177 in __libc_start_main (main=0x8197bd4 <main>, argc=2, ubp_av=0xbffff70c, init=0x8086330 <_init>, fini=0x82500c0 <_fini>, 
    rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffff6fc) at ../sysdeps/generic/libc-start.c:129
 [2004-05-21 22:14 UTC] danielc at analysisandsolutions dot com
I'm experienceing this on Windows builds as well.  The problem arose some time between these two snapshots:

works   php4-win32-STABLE-200401210130
crashes php4-win32-STABLE-200402161330
 [2004-05-21 22:34 UTC] thekid@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 22 18:01:24 2021 UTC