php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28276 function rename stopped working after the last Windows update
Submitted: 2004-05-04 19:28 UTC Modified: 2004-05-05 10:54 UTC
From: motion4u at hotmail dot com Assigned:
Status: Not a bug Package: Directory function related
PHP Version: 4.3.6 OS: Windows 2000 Advanced
Private report: No CVE-ID: None
 [2004-05-04 19:28 UTC] motion4u at hotmail dot com
Description:
------------
The function:
rename($oldname, $newname);
stopped working after the last windows update.
I'm using the rename Function to rename a directory

rename($oldname, $newname);

It doesn't work anymore... 
Before making a fool out of myself, I have double checked it.
If you think to answer that it might be that the directory is in use or a file within it is open ... the answer is no! I have restarted the server and the client and disconnected the internet plug for it.

Reproduce code:
---------------
just fill in the path to any subdirectory and call
<?
$old_dirname="";
$newdirname="";

$result=rename($old_dirname, $newdirname);

echo $result," old directory name: ",$old_dirname," new directory name: ",$newdirname;
?>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-05 04:19 UTC] motion4u at hotmail dot com
Sorry, it is not a bug! simply with this version the folders have to have more access permissions under windows as before.

I'm sure that it is mentioned somewhere in the documentations, which I have missed.

You may drop this report if you like.
 [2004-05-05 10:54 UTC] wez@php.net
Not a PHP bug then.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 09:01:24 2020 UTC