php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28267 php_image_filter_contrast calls gdImageBrightness?
Submitted: 2004-05-04 01:22 UTC Modified: 2004-05-09 19:41 UTC
From: hannes at mediagonal dot ch Assigned: pajoye
Status: Closed Package: GD related
PHP Version: 5CVS-2004-05-04 (dev) OS: Linux 2.6.5
Private report: No CVE-ID:
 [2004-05-04 01:22 UTC] hannes at mediagonal dot ch
Description:
------------
In http://lxr.php.net/source/php-src/ext/gd/gd.c#4064, the function php_image_filter_contrast calls gdImageBrightness where it probably should call gdImageContrast. This seems to work and seems to make sense, since gdImageContrast does not seem to be called from anywhere else.

Reproduce code:
---------------
 $img = imagecreatefromgif("http://images.slashdot.org/title.gif");
 imagefilter($img, 3, 50);
 imagejpeg($img);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-04 08:57 UTC] derick@php.net
Assigning to pierre.
 [2004-05-09 19:41 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 13:02:15 2014 UTC