php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2824 Inconsistent parameter list declaration for...
Submitted: 1999-11-24 20:03 UTC Modified: 2005-03-30 09:00 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: doellerer at forst dot tu-muenchen dot de Assigned:
Status: Wont fix Package: Compile Failure
PHP Version: 3.0.12 OS: HP-Ux 10.20
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [1999-11-24 20:03 UTC] doellerer at forst dot tu-muenchen dot de
The "Inconsistent parameter list declaration" error is displayed because it seems to me that configure doesn't recognise that "const" works correctly on HP-UX.

I was not able to correct this in configure, but here's a work around:
1. run configure
2. change config.h line 8
    from: #define const
    to:     #define const const

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-30 09:00 UTC] sniper@php.net
We are sorry, but we can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Of course PHP 4 will continue to be supported for the
forseeable future.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC