|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28146 PHP5RC2 Soap extension
Submitted: 2004-04-25 17:52 UTC Modified: 2004-04-25 20:05 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: mjsabby at gmail dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5CVS-2004-04-25 (dev) OS: Windows XP
Private report: No CVE-ID: None
 [2004-04-25 17:52 UTC] mjsabby at gmail dot com

the PHP extension of SOAP for PHP5RC2 doesn't work as expected.

On starting the apache server I get this message from Apache:

PHP Startup: soap: Unable to initialize module

Module compiled with module API=20040412, debug=0, thread-safety=1

PHP  compiled with module API=20040316, debug=0, thread-safety=1

These options need to match

Is this just a bug ? or something needs to done more at my end.



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-25 18:38 UTC]
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

You\'re using an old module with a newer PHP, that doesn\'t work.
 [2004-04-25 19:25 UTC] mjsabby at gmail dot com
Well this was in RC2, I don't know if the CVS has it updated.

But the bundled php_soap.dll with PHP5 RC2 just updated on your site today doesn't carry the files.
 [2004-04-25 20:05 UTC]
It's in there just fine, and it works fine me, and another PHP user I asked to verify this. You must be doing something wrong then.
 [2004-04-30 22:07 UTC] web at base dot gr
I have the same problem with mysql and sockets
PHP Startup: mysql ...
PHP Startup: sockets ...
I deleted the php directory and put the new verion.
Then replace the php.ini with a new one.
When I uncomment mysql and socket extensions I got this message...
(windows version ..)
 [2004-04-30 22:18 UTC] web at base dot gr
Sorry ....
OK I found the problem :)
Replace all old files NOT ONLY AT THE PHP DIRECTORY ... check system folders ... system32 ... for old files !!! :)
You are right it is a support problem ...
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC