php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28137 about half the extensions don't load
Submitted: 2004-04-24 19:51 UTC Modified: 2004-04-26 00:22 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bwacker at adelphia dot net Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.3.6 OS: WXP-Windows NT OFFICE 5.1 build
Private report: No CVE-ID: None
 [2004-04-24 19:51 UTC] bwacker at adelphia dot net
Description:
------------
extension_dir = C:\php\extensions
All of the following with ";" give "Unknown(): Unable to load dynamic library 'c:\php\extensions\php_*.dll' - The specified module cound not be found."

NOTE: all of the non ";" DO load, and good and bad are all in the extensions directory, so it is not php.ini.

phpinfo() can be found at http://users.adelphia.net/~bwacker/phpExtensionInfo.htm.

mhash is what I really need.

extension=php_bz2.dll
extension=php_cpdf.dll
extension=php_crack.dll
;extension=php_curl.dll
extension=php_db.dll
extension=php_dba.dll
extension=php_dbase.dll
extension=php_dbx.dll
;extension=php_domxml.dll
extension=php_exif.dll
;extension=php_fdf.dll
extension=php_filepro.dll
extension=php_gd2.dll
;extension=php_gettext.dll
extension=php_hyperwave.dll
;extension=php_iconv.dll
;extension=php_ifx.dll
;extension=php_iisfunc.dll
extension=php_imap.dll
;extension=php_interbase.dll
extension=php_java.dll
;extension=php_ldap.dll
extension=php_mbstring.dll
;extension=php_mcrypt.dll
;extension=php_mhash.dll
extension=php_mime_magic.dll
extension=php_ming.dll
;extension=php_mssql.dll
;extension=php_msql.dll
;extension=php_oci8.dll
;extension=php_openssl.dll
;extension=php_oracle.dll
;extension=php_pdf.dll
extension=php_pgsql.dll
;extension=php_printer.dll
extension=php_shmop.dll
extension=php_snmp.dll
extension=php_sockets.dll
;extension=php_sybase_ct.dll
extension=php_w32api.dll
;extension=php_xmlrpc.dll
;extension=php_xslt.dll
;extension=php_yaz.dll
extension=php_zip.dll


Reproduce code:
---------------
I've read one bug report where you said the problem is external libraries that have to be in the path. Do ALL of these fit that answer?

How can one determine which external libraries are missing so the path can be updated?

Note: All I really need now is mhash. The others are just there to prove that about half work and about half don't.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-24 20:10 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 [2004-04-25 00:13 UTC] bwacker at adelphia dot net
I could see punting to support if PHP couldn't load any extensions. Please explain why inconsistenies in being able to load some and not others doesn't constitute a bug in php dynamic extension loading. I've searched all the support information I can find, including general web searches and found a number of similar problems, none of which have a resolution. You also have some bug reports where the problem was accepted, but the responder concentrated on oracle, etc. extensions which may well require external libraries. What about all the others failing extensions? It apparently works on unix, but not on Windows. It walks like a bug and quacks like a bug, so please explain why you think it's a duck. Do you have any XP SP1 systems where the other half load with Apache 2.0 sapi php?
 [2004-04-25 02:46 UTC] wez@php.net
If you read the other similar sounding reports, you
will find that 99.999% of them are due to you having
a broken installation (old .dll's hanging around).
Since this is a bug database, and not a support forum,
you were encouraged to ask elsewhere, on pain of being
ignored.
 [2004-04-25 02:48 UTC] wez@php.net
or in this case, a broken PATH.
(best bet is to put all the PHP stuff together and put that dir in the path)
 [2004-04-25 05:29 UTC] bwacker at adelphia dot net
OK, some of them work when all /extensions and all /dlls are put into the same directory and it is pathed. So the bugs are 1) Not saying so in the pip.ini template where it talks about Windows, and 2) The error not saying "couldn't find at xxx OR PATH."

The other bugs are that the following still don't work, with the probable causes, but the only error given is not found instead of "not found or missing dependent .dll"

Of course, if support people write the error messages in the code and the scripts, then they aren't really bugs and nobody is responsible for fixing them and saving the next poor soul a day a thrashing around an "bugging" you guys.

The extensions that still don't work and possible causes:
;extension=php_ifx.dll 		needs ISQLT09A.DLL
;extension=php_iisfunc.dll	not in /extensions
;extension=php_mcrypt.dll	needs LIBMCRYPT.DLL
;extension=php_oci8.dll		needs OCI.DLL
;extension=php_oracle.dll	needs OCIW32.DLL
;extension=php_printer.dll	not in /extensions
;extension=php_sybase_ct.dll needs LIBCT.DLL and LIBCS.DLL
 [2004-04-26 00:22 UTC] sniper@php.net
Still bogus.

 [2004-05-07 18:07 UTC] eselon at yahoo dot com
Copy all the extension dir dlls at your systm32 directory and you're ok.
 [2011-08-07 03:59 UTC] gsantiago889 at hotmail dot com
Hello, i'am from argentine no speak english, but my problem is error with libcs.dll in php 5, please can you help me?. Thank
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 24 14:01:23 2021 UTC