|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27983 LDAP queries not working
Submitted: 2004-04-13 16:17 UTC Modified: 2004-04-17 21:49 UTC
From: cb at visionation dot com Assigned:
Status: Closed Package: LDAP related
PHP Version: 4.3.4 OS: OS X
Private report: No CVE-ID: None
 [2004-04-13 16:17 UTC] cb at visionation dot com
Apache: 1.3.29 (Darwin) 
mod_ssl: 2.8.16 
OpenSSL: 0.9.7b  
PHP 4.3.4

'./configure' '--prefix=/usr/local/php' '--with-config-file-path=/usr/local/php/lib' '--with-apxs' '--with-iconv=/usr/local/php' '--with-openssl=/usr' '--with-zlib=/usr' '--with-mysql' '--with-pgsql=/Users/marc/cvs/entropy/php-module/build/postgresql-build' '--enable-cgi' '--with-gd' '--with-png-dir=/usr/local/php' '--with-freetype-dir=/usr/local/php' '--with-t1lib=/usr/local/php' '--with-jpeg-dir=/usr/local/php' '--with-tiff-dir=/usr/local/php' '--with-curl=/usr/local/php' '--with-mcal=/usr/local/php' '--with-mcrypt=/usr/local/php' '--with-mhash=/usr/local/php' '--with-pdflib=/usr/local/php' '--with-imap=../imap-2002d' '--with-imap-ssl=/usr' '--with-expat-dir=/usr/local/php' '--with-gettext=/usr/local/php' '--with-dom=/usr/local/php' '--with-dom-xslt=/usr/local/php' '--with-dom-exslt=/usr/local/php' '--with-xslt-sablot=/usr/local/php' '--with-mssql=/usr/local/php' '--with-fbsql=/Users/marc/cvs/entropy/php-module/build/frontbase-build/Library/FrontBase' '--enable-xslt' '--with-ldap' '--with-xmlrpc' '--with-xml' '--with-iodbc' '--enable-sockets' '--enable-dbx' '--enable-dbase' '--enable-trans-sid' '--enable-exif' '--enable-wddx' '--enable-ftp' '--enable-mbstring' 

I have some LDAP queries happening within my pages.  These worked until Monday morning.  Now, when I have even the connect to LDAP function in my code the page cuts off completely.

From the apache logs I get this error when trying to connect:
[Tue Apr 13 12:48:10 2004] [notice] child pid 8653 exit signal Segmentation fault (11)

Here's what I'm getting in the slapd.log:
Apr 13 13:05:46 homer slapd[8557]: <= bdb_equality_candidates: (ou) index_param failed (18)

And there are no errors in my php error log.

Reproduce code:
Here's the code that I use to test what's happening:

echo "<h3>LDAP query test</h3>";
echo "Connecting ...";
 $ldapserver = "localhost";
// $ldapserver = "";
echo "ldapserver";


           $ds=ldap_connect($ldapserver);  // must be a valid LDAP server!
echo "ds $ds";
           if ($ds) {
//ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3);                                         $r=ldap_bind($ds);   // this is an "anonymous" bind, typically
             if ($r) {
               echo "bounded.";
           } else {
               echo "<h4>Unable to connect to LDAP server</h4>";
               return 0;

Expected result:
I expect to see the echo responses printing and the page not hang.  This worked until recently.

Actual result:
this is what is printing out...

LDAP query test 

connecting... ldapserver

the phpinfo stuff

and then it hangs.....


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-13 17:04 UTC]
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

Also, what changed on Monday? (if it worked til that, something MUST have changed..)

 [2004-04-17 21:49 UTC] cb at visionation dot com
I added
the line:
ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3);

and things began working more consistantly.  I'm not sure
why things worked before and didn't later, but this seemed
to fix the problem.

Thanks for your help!
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Fri Dec 01 13:01:26 2023 UTC