php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27751 Apache2 2.0.49 crash when restarting (PHP4.3.5 only, works fine in 4.3.4)
Submitted: 2004-03-29 08:20 UTC Modified: 2004-04-01 07:03 UTC
From: packager at rabbito dot org Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.3.5 OS: Windows XP
Private report: No CVE-ID:
 [2004-03-29 08:20 UTC] packager at rabbito dot org
Description:
------------
Apache2 2.0.49 crash when restarting Apache2 from Apache Service Monitor under PHP4.3.5

Works fine (no crash) with PHP-4.3.4, Apache2.0.49.

Expected result:
----------------
Apache2 should exit without application error

Actual result:
--------------
The following Apache Application Error occurs
---------------------------------------------

The instruction at "0x77f83aed" referenced memory at "0x37412d32". The memory could not be "written".

Click on OK to terminate the program
Click on CANCEL to debug the program

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-29 08:23 UTC] packager at rabbito dot org
The crash only occur after the first PHP script is executed, ie) someone requested a url that is generated by PHP.

Uses standard php.ini file and a slightly modified httpd.conf file with the following lines added:
   LoadModule php4_module C:\www\php\sapi\php4apache2.dll
   AddType application/x-httpd-php .php
 [2004-03-29 10:46 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe of bug #27735 
 [2004-03-30 22:45 UTC] josestefan at hotmail dot com
I've noticed that disabling all CustomLog in apache's httpd conf file avoids the crash. So maybe that's a good place for the developers to start looking. 

I have log_errors = Off on my php.ini file, so it really doesn't make sense to me. But I have confirmed that with the CustomLogs disabled, I get no crashes.
 [2004-03-30 23:59 UTC] josestefan at hotmail dot com
sorry, my report is wrong. I forgot that the error occurs after the first php request, when I did my testing.
 [2004-04-01 05:41 UTC] packager at rabbito dot org
Please refer to:

http://bugs.php.net/bug.php?id=27810
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 14:02:33 2014 UTC