php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27717 Test Failures when compiled on 64-bit mode + Segmentation Fault
Submitted: 2004-03-26 10:48 UTC Modified: 2004-04-05 04:15 UTC
From: joelee at joeworks dot com Assigned:
Status: Closed Package: Reproducible crash
PHP Version: 5.0.0RC1 OS: Linux (Suse Linux 9.0 for AMD64)
Private report: No CVE-ID:
 [2004-03-26 10:48 UTC] joelee at joeworks dot com
Description:
------------
make test failure on abs(), pow() and round() when compile in 64-bit mode

Tested on both 5.0.0RC1 and 4.3.5

Reproduce code:
---------------
# Compile in 64-bit mode
$ ./configure
$ make
$ make test
# Actual Result


# Compiled in 32-bit mode
$ CFLAGS=-m32 ./configure
$ make
$ make test
# Expected result

Expected result:
----------------
=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
Bug #25547 (error_handler and array index with function call)
[tests/lang/bug25547.phpt]
=====================================================================

Actual result:
--------------
=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
Bug #24054 (Assignment operator *= broken) [tests/lang/bug24054.phpt]
Bug #25547 (error_handler and array index with function call)
[tests/lang/bug25547.phpt]
serializing references test case using globals
[ext/session/tests/019.phpt]
Simple math tests [ext/standard/tests/math/abs.phpt]
Various pow() tests [ext/standard/tests/math/pow.phpt]
Simple math tests [ext/standard/tests/math/round.phpt]
=====================================================================

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-26 10:56 UTC] joelee at joeworks dot com
Tested on both 5.0.0RC1 and 4.3.5

Result from 5.0.0RC1
=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
ZE2 __toString() [tests/classes/tostring.phpt]
ZE2: set_exception_handler() [tests/lang/035.phpt]
Bug #22367 (weird zval allocation problem) [tests/lang/bug22367.phpt]
Bug #23279 (exception handler stops after first function call) [tests/lang/bug23279.phpt]
Bug #23384 (use of class constants in statics) [tests/lang/bug23384.phpt]
Bug #26866 (segfault when exception raised in __get) [tests/lang/bug26866.phpt]
ZE2 errors caught as exceptions [tests/lang/error_2_exception_001.phpt]
invoke with non object or null value [tests/reflection/invoke.phpt]
Bug #22836 (returning references to NULL) [Zend/tests/bug22836.phpt]
Bug #26166 (__toString() crash when no values returned) [Zend/tests/bug26166.phpt]
Bug #26698 (Thrown exceptions while evaluting argument to pass as parameter crash PHP) [Zend/tests/bug26698.phpt]
Test 3: Exception Test [ext/dom/tests/dom003.phpt]
sqlite-oo: factory and exception [ext/sqlite/tests/sqlite_oo_020.phpt]
sqlite-oo: and spl [ext/sqlite/tests/sqlite_oo_031.phpt]
Bug #25038 (call_user_func issues warning if function throws exception) [ext/standard/tests/general_functions/bug25038.phpt]
date_sunrise() and date_sunset() functions [ext/standard/tests/general_functions/sunfuncts.phpt]
Bug #26614 (CDATA sections skipped on line count) [ext/xml/tests/bug26614.phpt]
=====================================================================
 [2004-03-26 11:11 UTC] derick@php.net
Please add a link to the information that "make test" saved to disk.
 [2004-03-26 12:35 UTC] joelee at joeworks dot com
As requested, link to make test results:

PHP 4.3.5
http://joeworks.com/pickup/php4.3.5_test_results_20040326.txt

PHP 5.0.0RC1
http://joeworks.com/pickup/php5.0.0RC1_test_results_20040324_1124.txt
 [2004-03-26 13:41 UTC] iliaa@php.net
The PHP4 tests failures you've indicated are not 'real' 
failures, the results simply do not match since integers on 
your system can go much further then on 32 bit systems. 
 [2004-03-30 12:41 UTC] joelee at joeworks dot com
PHP5 ApacheHandler & CLI crashes with Segmentation Fault whenever E_ERROR occured.
 [2004-04-05 04:15 UTC] abies@php.net
The issues that were reproducible on FreeBSD/Alpha were fixed. [that should cover all PHP4 failures] 
Please file a new bug report for PHP5 if you still experience 64-bit issues with PHP5-CVS
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 25 07:02:14 2014 UTC