php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27519 Reflection_Function constructor crashes with non-existant function's name
Submitted: 2004-03-07 14:13 UTC Modified: 2004-04-08 16:40 UTC
From: su1d at phpclub dot net Assigned: helly
Status: Closed Package: Scripting Engine problem
PHP Version: 5.0.0RC1-dev OS: *
Private report: No CVE-ID:
 [2004-03-07 14:13 UTC] su1d at phpclub dot net
Description:
------------
E:\>php -v
PHP 5.0.0b4 (cli) (built: Feb 12 2004 18:00:13)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.0-dev, Copyright (c) 1998-2004 Zend Technologies

E:\>php -r "$F = new Reflection_Function('abs');"

E:\>php -r "$F = new Reflection_Function('no_function');"
** BANG! **


Reproduce code:
---------------
$F = new Reflection_Function('no_function');



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-07 15:39 UTC] derick@php.net
Can't reproduce this on Linux. What is the full error message you get?
 [2004-03-07 16:16 UTC] su1d at phpclub dot net
Just a common Windows system MessageBox appears notifying me about an error:

php.exe - Application Error
The instruction at "0x100007164" referenced memory at "0xfffffff8". The memory could not be "read".
Click "OK" to terminate the program
blah-blah-blah...
 [2004-03-09 20:01 UTC] su1d at phpclub dot net
PHP 5.0.0RC1-dev (cli) (built: Mar 10 2004 00:17:49)
I'm sorry, but I have to admit that the bug remains in the newest build.

We need someone else to check the issue out on a Windows system.
 [2004-03-26 10:51 UTC] tony2001 at phpclub dot net
I can confirm this bug with latest snapshot (php5-win32-200403261130).
I've no ideas how to debug it under win32, so if you tell me how to get the backtrace or something more useful, than this silly error message, I'll try to help, of course.
 [2004-04-08 11:49 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip

And note that the Reflection_Function is now renamed to ReflectionFunction..

 [2004-04-08 12:43 UTC] su1d at phpclub dot net
Negative. 
The bug persists:

C:\>php -v
PHP 5.0.0RC2-dev (cli) (built: Apr  8 2004 16:16:41)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v2.0.0RC2-dev, Copyright (c) 1998-2004 Zend Technologies

C:\>php -r "$r = new ReflectionFunction('abs');"

C:\>php -r "$r = new ReflectionFunction('nofunc');"
** CRASH **
 [2004-04-08 16:40 UTC] helly@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 02:02:10 2014 UTC