php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #27489 upload_permissions would be a cool option
Submitted: 2004-03-04 04:06 UTC Modified: 2015-01-08 22:50 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: joe at mcknight dot de Assigned:
Status: Wont fix Package: *General Issues
PHP Version: 4.3.4 OS: Linux 2.4.25
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-03-04 04:06 UTC] joe at mcknight dot de
Description:
------------
Hi,

I'd really like to see an option upload_permissions because in my webserver configuration I need group/world read permission for the file (the owner of the file is the user, the group is the customer and the httpd user is among others).

strace shows that the file is always created with 0600 permission in the tmp-path, then moved and after that I'd like to change permissions to 644...

Sure, people could do a chmod() in their php source but if someone wants to migrate to my server and he has to change 300 php files, he'll complain...

Thx,
Joachim


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-01-08 22:50 UTC] ajf@php.net
-Status: Open +Status: Wont fix -Package: Feature/Change Request +Package: *General Issues
 [2015-01-08 22:50 UTC] ajf@php.net
I don't see what's wrong with just using chmod().
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Sep 20 12:01:28 2018 UTC