php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27417 feof under register_stream
Submitted: 2004-02-27 09:28 UTC Modified: 2004-03-09 19:06 UTC
From: phillip dot hegarty at ntlworld dot com Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 5.0.0b4 (beta4) OS: *
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: phillip dot hegarty at ntlworld dot com
New email:
PHP Version: OS:

 

 [2004-02-27 09:28 UTC] phillip dot hegarty at ntlworld dot com
Description:
------------
Example code from current documentation of the 
stream_register_wrapper function includes an feof test.

This always returns a non-false value.

Code works on 4.3.4 but not on 5.0.0b4.

Altered class function "stream_eof" to emit debug message, which duly echoe'd but whatever this function returns, the
feof returns true !


Reproduce code:
---------------
See example code from online documentation of the 
stream_register_wrapper function

Expected result:
----------------
Expected feof to return false


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-07 16:34 UTC] phillip dot hegarty at ntlworld dot com
This is the same as Bug #27508
 [2004-03-07 16:59 UTC] wez@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip

Most likely fixed now
 [2004-03-09 15:53 UTC] phillip dot hegarty at ntlworld dot com
This still fails with the latest snapshot - stream_eof() return value does not affect return value from feof().
 [2004-03-09 19:06 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe of bug #27508, marking this one as dupe since the 
other bug has more information. 
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 22 22:01:24 2020 UTC