php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27407 socket_select crashes
Submitted: 2004-02-26 14:26 UTC Modified: 2004-03-18 09:18 UTC
From: flapc at pobox dot sk Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.3.4 OS: Linux
Private report: No CVE-ID: None
 [2004-02-26 14:26 UTC] flapc at pobox dot sk
Description:
------------
socket_select crashes. Even I get no input from the script sent before the call.

I cannot check it deeply because I experienced the problem on my webhosting server.

On Win distribution everthing runs fine...

Reproduce code:
---------------
http://dave.dapond.com/socketselect.php.txt


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-04 09:03 UTC] flapc at pobox dot sk
There is no problem on Windows.
The problem is on LINUX..
 [2004-03-04 09:06 UTC] derick@php.net
Right, and that's why the first URL he posted was to a linux source snapshot, please test with that one.
 [2004-03-04 11:10 UTC] flapc at pobox dot sk
That i've found out .. 
But I've no idea of compiling from sources.
After unpacking it i runned

'./configure' '--enable-inline-optimization' '--enable-pic' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-ftp' '--enable-bcmath' '--enable-exif' '--enable-ctype' '--with-imap-ssl=/usr' '--with-openssl=/usr'  '--enable-sockets' '--enable-trans-sid' '--enable-sigchild'  '--enable-magic-quotes'  '--enable-zend-multibyte'  '--with-bz2'  '--enable-shared' '--enable-memory-limit' '--disable-posix' '--disable-tokenizer'  '--disable-rpath'  '--enable-mbstring' '--enable-mbregex' '--enable-wddx' 

and then 

make

but i'm not allowed to run 
make install

I got cli version of php, but THERE WAS no SOCKETS(.SO) ..
how to build the sockets?
 [2004-03-06 14:13 UTC] iliaa@php.net
Sockets extension was compiled directly into your PHP, 
there is no need to load sockets.so. 
 [2004-03-11 09:54 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2004-03-18 09:14 UTC] flapc at pobox dot sk
I've tested it on Mandrake 9.2 + Apache 1.3 ... newest 
PHPsnap and it worked. i is somehow bound with firewall, 
because i haven't used none port restrictions, but on my 
webhosting provider's server it DOES NOT work... WHY???
 [2004-03-18 09:18 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Apr 04 10:01:25 2020 UTC