php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27357 Configure reports zlib version wrong when iconv missing
Submitted: 2004-02-22 19:42 UTC Modified: 2004-02-22 22:17 UTC
From: work at zguy dot com Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 5.0.0b4 (beta4) OS: Solaris 8
Private report: No CVE-ID: None
 [2004-02-22 19:42 UTC] work at zguy dot com
Description:
------------
Running configure on my system I get:
./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin/apxs --with-zlib=/usr/local
...
checking if the location of ZLIB install directory is defined... no
checking for gzgets in -lz... no
configure: error: ZLIB extension requires zlib >= 1.0.9

Eventually I think to check config.log and find:
configure:19568: gcc -o conftest -g -O2  -D_POSIX_PTHREAD_SEMANTICS -R/usr/loca
l/lib -L/usr/local/lib  -R/usr/ucblib -L/usr/ucblib -R/usr/local/lib/gcc-lib/sp
arc-sun-solaris2.8/3.3.2 -L/usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.3.2 -R
/usr/local/lib -L/usr/local/lib conftest.c -lz  -lresolv -lm -ldl -lnsl -lsocke
t  -lgcc -lxml2 -lz -liconv -lm -lsocket -lnsl 1>&5
ld: fatal: library -liconv: not found
ld: fatal: File processing errors. No output written to conftest
collect2: ld returned 1 exit status

Expected result:
----------------
It would be nicer if it checked for iconv and reported it missing rather than complaining about the zlib version.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-22 22:17 UTC] sniper@php.net
The missing iconv library comes from libxml2 setup.
Try this:

# xml2-config --libs

I added build test into configure for libxml2 stuff to
catch the error earlier.

(the missing libiconv is not our problem but problem in your system..)

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jul 20 07:01:28 2024 UTC