php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27347 Cannot query SNMPv1 devices (version cannot be set)
Submitted: 2004-02-22 08:42 UTC Modified: 2004-03-01 02:29 UTC
From: Ernest at Beinrohr dot sk Assigned:
Status: Not a bug Package: SNMP related
PHP Version: 4.3.4 OS: linux 2.4
Private report: No CVE-ID: None
 [2004-02-22 08:42 UTC] Ernest at Beinrohr dot sk
Description:
------------
I use the newest stable php 4.3.4 and I cannot query my old jetdirect network device with php-snmp. With command line tools it works only when I specify version 1.



linux 2.4.22
net-snmp-5.1

Reproduce code:
---------------
with SNMPv1 devices

Expected result:
----------------
should get a response

Actual result:
--------------
no response from SNMPv1 device.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-23 03:20 UTC] Ernest at Beinrohr dot sk
Ok, but this fails only with SNMPv1 device. That's the problem.

<?php
$printer_oid = ".iso.org.dod.internet.4.1.11.2.3.9.1.1.3.0";
snmpget("jetdirect", "public", $printer_oid));

?>
 [2004-02-26 15:48 UTC] sniper@php.net
Forgot to ask: EXACTLY what error do you get?
(About the version: It _is_ set to 1 in snmpget() )

 [2004-02-27 03:22 UTC] Ernest at Beinrohr dot sk
in php-4.3.4 new install the bug has not show up.


damn, sorry for robbing your time.
 [2004-03-01 02:29 UTC] magnus@php.net
Not a bug -> Bogus
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 11:01:24 2020 UTC