php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27279 Database data not stripped - whitespace everywhere
Submitted: 2004-02-16 09:40 UTC Modified: 2004-02-18 12:18 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: webmaster at birkman dot com Assigned:
Status: Not a bug Package: Sybase (dblib) related
PHP Version: 4.3.4 OS: Linux 2.4 to MSSQL2000
Private report: No CVE-ID: None
 [2004-02-16 09:40 UTC] webmaster at birkman dot com
Description:
------------
In looking at the ChangeLog, I don't see anything describing the behavior I'm seeing. Most of the data returned from the database has whitespace at the end, even bits and integers. 

Has something changed requiring the use of trim() on every resultset coming from a sybase database? Wouldn't a trim() operation in C be faster than one in PHP?

This behavior occurs in PHP-4.3.4 but not in our production version of PHP-4.3.2

Thanks,
David Steckbeck


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-16 11:05 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

This is due to a bug in the library not PHP. For more 
information search for similar bugs (there were several). 
 [2004-02-17 08:46 UTC] webmaster at birkman dot com
I searched on various keywords (whitespace, sybase, spacing, extra spaces) and nothing came up related to this issue of 4.3.2 -> 4.3.4 spacing. If you wouldn't mind, could you please post links to the bugs you're referencing, and I'll be more than happy to move my comments?

Also, I have CLI versions of 4.3.2 and 4.3.4 both built with the exact same libraries showing the bug. And I have a 4.3.4 version built (exact same way) except the 'if ilia_0' has been commented out of php_sybase_db.c, and it works fine.
 [2004-02-18 08:16 UTC] webmaster at birkman dot com
Changed status to open
 [2004-02-18 11:47 UTC] sniper@php.net
Please don't open this anymore, search again.

 [2004-02-18 12:18 UTC] webmaster at birkman dot com
Hey Again,

   I'm not trying to be pedantic here but I did try searching for a wide variety of keywords in order to locate the existing bug you referred to.  Since I've had no luck thusfar, might you be so kind as to just supply me with a direct link to the already-open bug that my bug was a duplicate of?  I'm more than willing to allow my bug to be deemed "closed/bogus" if it is in fact a duplicate, I'd just like a chance to review the original bug to reassure myself that my bug was indeed redundant.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 19 22:01:25 2019 UTC