php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27264 segfault with soapclient::__getTypes()
Submitted: 2004-02-15 14:17 UTC Modified: 2004-02-15 16:29 UTC
From: schlueter at phpbar dot de Assigned:
Status: Closed Package: SOAP related
PHP Version: 5.0.0b4 (beta4) OS: Linux
Private report: No CVE-ID: None
 [2004-02-15 14:17 UTC] schlueter at phpbar dot de
Description:
------------
Everytime I use the soapclient::__getTypes() on a SOAP Client object I get a segfault. I've tried different WSDLs. A simple example Script is attached.
Build environment: Linux 2.6.2, glibc 2.3.2, gcc 3.2.3, libxml2 2.6.3

configure line:
./configure --disable-all \
            --enable-soap \
            --prefix=/opt/php5/bin \
            --with-config-file-path=/opt/php5/etc \
            --disable-cli


Reproduce code:
---------------
<?php
$soap = new soapclient('http://helena.europe.webmatrixhosting.net/Morse.asmx?WSDL');
$soap->__getTypes();
?>


Expected result:
----------------
no output

Actual result:
--------------
$ gdb /opt/php5/bin/php
GNU gdb 5.3
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
(gdb) run soap.php
Starting program: /opt/php5/bin/php soap.php

Program received signal SIGSEGV, Segmentation fault.
0x080a96db in type_to_string (type=0x40351cb4, buf=0xbfffce40, level=0)
    at /home/johannes/src/php-5.0.0b4/ext/soap/soap.c:3264
3264                    smart_str_appendl(buf, ";\n", 2);
(gdb) bt
#0  0x080a96db in type_to_string (type=0x40351cb4, buf=0xbfffce40, level=0)
    at /home/johannes/src/php-5.0.0b4/ext/soap/soap.c:3264
#1  0x080a4535 in zif_soapclient___gettypes (ht=0, return_value=0x40351894,
    this_ptr=0x0, return_value_used=0)
    at /home/johannes/src/php-5.0.0b4/ext/soap/soap.c:2046
#2  0x081dafb0 in zend_do_fcall_common_helper (execute_data=0xbfffcfd0,
    opline=0x4035179c, op_array=0x4035133c)
    at /home/johannes/src/php-5.0.0b4/Zend/zend_execute.c:2642
#3  0x081db093 in zend_do_fcall_by_name_handler (execute_data=0x40354094,
    opline=0x0, op_array=0x0)
    at /home/johannes/src/php-5.0.0b4/Zend/zend_execute.c:2753
#4  0x081d7468 in execute (op_array=0x4035133c)
    at /home/johannes/src/php-5.0.0b4/Zend/zend_execute.c:1339
#5  0x081b937e in zend_execute_scripts (type=8, retval=0x0, file_count=3)
    at /home/johannes/src/php-5.0.0b4/Zend/zend.c:1052
#6  0x0818241e in php_execute_script (primary_file=0xbffff3a0)
    at /home/johannes/src/php-5.0.0b4/main/main.c:1647
#7  0x081e2c32 in main (argc=2, argv=0xbffff424)
    at /home/johannes/src/php-5.0.0b4/sapi/cli/php_cli.c:941
#8  0x4022bd6b in __libc_start_main () from /lib/libc.so.6
(gdb)
#0  0x080a96db in type_to_string (type=0x40351cb4, buf=0xbfffce40, level=0)
    at /home/johannes/src/php-5.0.0b4/ext/soap/soap.c:3264
#1  0x080a4535 in zif_soapclient___gettypes (ht=0, return_value=0x40351894,
    this_ptr=0x0, return_value_used=0)
    at /home/johannes/src/php-5.0.0b4/ext/soap/soap.c:2046
#2  0x081dafb0 in zend_do_fcall_common_helper (execute_data=0xbfffcfd0,
    opline=0x4035179c, op_array=0x4035133c)
    at /home/johannes/src/php-5.0.0b4/Zend/zend_execute.c:2642
#3  0x081db093 in zend_do_fcall_by_name_handler (execute_data=0x40354094,
    opline=0x0, op_array=0x0)
    at /home/johannes/src/php-5.0.0b4/Zend/zend_execute.c:2753
#4  0x081d7468 in execute (op_array=0x4035133c)
    at /home/johannes/src/php-5.0.0b4/Zend/zend_execute.c:1339
#5  0x081b937e in zend_execute_scripts (type=8, retval=0x0, file_count=3)
    at /home/johannes/src/php-5.0.0b4/Zend/zend.c:1052
#6  0x0818241e in php_execute_script (primary_file=0xbffff3a0)
    at /home/johannes/src/php-5.0.0b4/main/main.c:1647
#7  0x081e2c32 in main (argc=2, argv=0xbffff424)
    at /home/johannes/src/php-5.0.0b4/sapi/cli/php_cli.c:941
#8  0x4022bd6b in __libc_start_main () from /lib/libc.so.6

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-15 15:50 UTC] schlueter at phpbar dot de
Next time I check HEAD. Next time Icheck HEAD. Next time I 
check HEAD. 
 
The Bug seems to be fixed in CVS.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC