php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #27248 php_exif.dll crashes php
Submitted: 2004-02-13 20:43 UTC Modified: 2004-02-17 21:09 UTC
Votes:3
Avg. Score:4.7 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:2 (66.7%)
From: zeger at zeger dot nl Assigned:
Status: Closed Package: Documentation problem
PHP Version: 5CVS-2004-02-14 OS: Windows 2k3 Server
Private report: No CVE-ID: None
 [2004-02-13 20:43 UTC] zeger at zeger dot nl
Description:
------------
Using IIS 6.0 in ISAPI mode:

Loading the php_exif.dll module gives an "Invalid access to memory location. " error, php stops.

Using IIS 6.0 in CGI mode

Loading the php_exif.dll module crashes php.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-16 11:58 UTC] ian_germany at hotmail dot com
I have a similar problem, running php.exe (Version 5 beta 4) from the commmandline (Windows XP). 

Enabling php_exif.dll in php.ini makes php crash, without it everything is fine. Other extensions such as php_gd2.dll are working fine. I have no previous versions of PHP installed.
 [2004-02-16 14:17 UTC] helly@php.net
Are you using mbstring extension? If not load it and try again.
 [2004-02-17 04:09 UTC] ian_germany at hotmail dot com
Yes, mbstring is added. Without php_exif all is fine. 

If I dont have php_exif.dll in the root of the php folder php appears unable to find it, even though it is with all the other extensions and can find them.

this is the error I get :

This application has failed to start because php_mbstring.dll was not found. Re-installing the application may fix this problem.

followed by:

PHP Startup:Unable to load dynamic library 'c:/php/ext/php_exif.dll' - The specified module could not be found.
 [2004-02-17 05:10 UTC] mastabog at hotmail dot com
I can confirm this bug.

I'm downloading the php5-win32-latest.zip daily and use it with apache1.3 and apache2.

Since the release of beta 3, all versions were always crashing while loading the php_exif.dll (even if php_mbstring.dll was also loaded) unless php_exif.dll was copied in the php5apache.dll directory (in my case the php5 dir).
 [2004-02-17 06:46 UTC] zeger at zeger dot nl
After some further experiments using PHP 5.0.0 snapshots in the command prompt.

Loading php_exif.dll results in an error "php_mbstring.dll was not found". Loading php_mbstring.dll works just fine. Loading both php_exif.dll and mbstring.dll results in "php_mbstring.dll was  not found".

Next, copying the php_mbstring.dll to the php.exe root results in a php crash when loading php_exif.dll.
 [2004-02-17 14:06 UTC] wez@php.net
Please try this:

php.ini:
extension=php_mbstring.dll
extension=php_exif.dll

NOTE: the order is important.

If that doesn't work, try modifying your PATH to
include the PHP extension dir, then try again.


 [2004-02-17 15:20 UTC] zeger at zeger dot nl
php-cgi.exe works!

php.ini excerpt :

extension=php_mbstring.dll
extension=php_exif.dll

So I guess loading php_mbstring has to be done prior to loading php_exif.
 [2004-02-17 17:14 UTC] sniper@php.net
This should be documented somewhere..

 [2004-02-17 21:09 UTC] irchtml@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2012-10-07 03:57 UTC] vergil dot arash at yahoo dot com
hi 
I have the same problem but it's not work for me and I cant run wampserver
when I put it online I have this one too
could not execute menu item(internal error) [exception] could not perform servise action:the servise has not been started
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Nov 14 16:01:27 2018 UTC