php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27245 phpize fails to find libtoolize on FreeBSD
Submitted: 2004-02-13 13:40 UTC Modified: 2004-02-13 13:52 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: ikindred at cox dot net Assigned:
Status: Wont fix Package: Compile Failure
PHP Version: 4.3.4 OS: FreeBSD
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-02-13 13:40 UTC] ikindred at cox dot net
Description:
------------
phpize relies on shtool to find libtoolize, as can be seen in the following excerpt from phpize (php 4.3.4):

libtoolize=`$builddir/build/shtool path glibtoolize libtoolize`
$libtoolize -f -c || exit 1

However, on FreeBSD 4.8 (and probably other versions of FreeBSD), there is no libtoolize.  Instead there is libtoolize13, libtoolize14 and/or libtoolize15.  I'm guessing that which libtoolizeXX versions are installed depends on which versions of libtoolXX are install, but I have not confirmed this.

This problem does not prevent PHP from compiling.  However, it does prevent modules that depend on phpize from compiling.  I ran into this problem while trying to add SQLite support to PHP 4.3.4.

A solution would be to add libtoolize13, libtoolize14 and libtoolize15 to the list of "paths" that shtool searches.  However, as libtoolizeXX's probably only exist on FreeBSD, I'm not sure the PHP team will want to make this platform specific fix.  Another solution would be to have the FreeBSD PHP port maintainer adjust the port to patch phpize when it gets installed.

I believe that the same problem with phpize on FreeBSD exists with PHP 5.0.x, but I may be wrong about this.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-13 13:52 UTC] derick@php.net
Not a bug in PHP really, we can't help that FreBSD's port is fucked up :)
 [2004-09-18 17:11 UTC] jurgen at person dot be
Derick,

I don't agree with You on this.

We have the same problem here with php 4.3.8 and FreeBSD 5.2.1
Compiling Xdebug2 fails for the same reason.

php 4.3.8 was installed from SOURCE !

It's a little work to modify the script phpize to verify if the OS is freebsd and to catch this problem !

The error is not on FreeBSD but on phpize
 [2004-09-18 17:18 UTC] jurgen at person dot be
O and I forget something.

The version of shtool is pretty old !  
#/usr/local/lib/php/build/shtool -v
GNU shtool 1.6.2 (02-Nov-2002)

Why to include shtool, if it's a separate package or tool to install (/usr/ports/devel/shtool) ?

#/usr/local/bin/shtool -v
GNU shtool 2.0.1 (11-Aug-2004)

So I suggest at least to symlink.

#cd /usr/local/lib/php/build
#mv shtool shtool.old
#ln -s /usr/local/bin/shtool

But the problem of libtoolize remains remeans
when You need phpize to buid a module (in this 
case Xdebug)

#cd /usr/local/src/xdebug-2.0.0beta1
#phpize --clean
#phpize
autoheader: `config.h.in' is created
-f: not found

* line (/usr/local/bin/phpize) :
* libtoolize=`$builddir/build/shtool path glibtoolize libtoolize`
* $libtoolize -f -c || exit 1

:-)
 [2004-09-18 17:44 UTC] jurgen at shop dot fr
So the solution or patch for phpize is :

-libtoolize=`$builddir/build/shtool path glibtoolize libtoolize`
+if test $HOSTTYPE = "FreeBSD"; then
+        libtoolize=`$builddir/build/shtool path glibtoolize libtoolize15`    
+else
+        libtoolize=`$builddir/build/shtool path glibtoolize libtoolize`
+fi
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC