php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27116 SimpleXMLIterator
Submitted: 2004-02-01 22:02 UTC Modified: 2004-02-16 15:10 UTC
From: yannl at istop dot com Assigned:
Status: Closed Package: *XML functions
PHP Version: 5CVS-2004-02-01 (dev) OS: Linux
Private report: No CVE-ID: None
 [2004-02-01 22:02 UTC] yannl at istop dot com
Description:
------------
Apache does'nt start even if it says so.

I found this error in the apache error_log file

PHP Fatal error:  Class SimpleXMLIterator may not inherit from final class (~K]?~I?]?~Mt&) in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-02-02 02:22 UTC] helly@php.net
Please do a full rebuild (./cvsclean ; ./buildconf ; ./configure ...) and report back if the error stays. 
 [2004-02-03 22:55 UTC] yannl at istop dot com
Running ./cvsclean was ok

Got this error will running buildconf.

using default Zend directory
buildconf: checking installation...
buildconf: autoconf version 2.57 (ok)
buildconf: Your version of autoconf likely contains buggy cache code.
           Running cvsclean for you.
           To avoid this, install autoconf-2.13 and automake-1.5.
buildconf: libtool version 1.4.3 (ok)

Building php was ok.

Apache will start (httpd.pid is created) but no page can be served by apache and no errors are logged in error_log.
 [2004-02-04 02:26 UTC] helly@php.net
Are you using SPL or SimpleXML as a shared extension (e.g. what's your configure line).
 [2004-02-09 11:41 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip

And skip the './cvsclean && ./buildconf' parts helly suggested..(I don't think your build tools are correct to generate working configure, etc., using snapshots is "safe")



 [2004-02-15 09:00 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2004-02-16 15:10 UTC] helly@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 21:01:23 2020 UTC