php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27089 Can't even configurate PHP with OpenSSL support
Submitted: 2004-01-29 13:59 UTC Modified: 2005-08-18 01:00 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: apalma at custodium dot com Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: php4-STABLE-200402011830 OS: RedHat Linux 7.2
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-01-29 13:59 UTC] apalma at custodium dot com
Description:
------------
I'm trying to install PHP 4.3.4 in a RedHat Linux 7.2 box, adding support for Oracle8i (that's the reason why I don't use the rpm PHP distribuited by RedHat). But every time I run the configure with support for openssl (--with-openssl), I get an error:

checking for CRYPTO_free in -lcrypto... no 
configure: error: libcrypto not found!

I got all the dependences installed in the machine (openssl, openssl095a, openssl096 and openssl-devel are installed), with the following shared object created in the system:

libcrypto.a
libcrypto.so -> ../../lib/libcrypto.so.0.9.6b
libcrypto.so.0 -> libcrypto.so.0.9.5a
libcrypto.so.0.9.5a
libcrypto.so.0.9.6
libcrypto.so.1 -> libcrypto.so.0.9.6
libssl.a
libssl.so -> ../../lib/libssl.so.0.9.6b
libssl.so.0 -> libssl.so.0.9.5a
libssl.so.0.9.5a
libssl.so.0.9.6
libssl.so.1 -> libssl.so.0.9.6

In fact, if I compile the source rpm provided by RedHat, I get the same error:

rpmbuild --rebuild --target=i386 php-4.1.2-7.2.6.src.rpm

checking for CRYPTO_free in -lcrypto... no 
configure: error: libcrypto not found!

but I guess this is not your business :-D

Reproduce code:
---------------
./configure --with-openssl

Expected result:
----------------
I'd like to see a successful Makefile created after the configure script is run.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-29 16:49 UTC] sniper@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

You really should have searched the bug database first. :)

 [2004-01-30 19:50 UTC] apalma at custodium dot com
I tried the previous suggestion, download the latest stable snapshot at Jan 30, but the error still persists.
 [2004-01-31 23:46 UTC] sniper@php.net
Check config.log for the exact reason why the test fails.

 [2004-02-01 15:40 UTC] apalma at custodium dot com
The log says:

configure:16122: checking for OpenSSL version
configure:16262: checking for CRYPTO_free in -lcrypto
configure:16281: gcc -o conftest -g -O2   conftest.c -lcrypto  -lresolv -lm -ldl -lnsl -lpthread 1>&5
/usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../libcrypto.so: undefined reference to `__sysconf@GLIBC_2.2'
collect2: ld returned 1 exit status
configure: failed program was:
#line 16270 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char CRYPTO_free();

int main() {
CRYPTO_free()
; return 0; }

********************************************************
I only keep openssl and openssl-devel packages in this machine, and removed openssl095a and openssl096
 [2005-08-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 23:01:32 2024 UTC