php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27077 Changing 'mssql.textsize' in php.ini causes connections to stop working
Submitted: 2004-01-28 12:57 UTC Modified: 2004-01-30 11:13 UTC
From: jason at burfield dot com Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.3.4 OS: Linux ( Suse 9 )
Private report: No CVE-ID: None
 [2004-01-28 12:57 UTC] jason at burfield dot com
Description:
------------
PHP, configured as such:

'./configure' '--with-mssql=/usr/local' '--with-apxs=/usr/sbin/apxs' '--with-mcrypt=/usr/local' '--enable-trans-id'

Use Suse 9.0
Using Apache 1.3.28
Using FreeTDS.

I encountered a problem with the 'textsize' and 'textlimit' values in the PHP.INI file when using SQL Server.

If left to their default values (commented out) everything is fine, however, when I change the value to a larger size, in this case up to 10000, Apache starts and all seems fine, however, connecting to the SQL Server database machine stops working.

If I change the limit back to default the connections start working again.

I also attempted changing the settings in freetds.conf, however, that had no effect at all.

Reproduce code:
---------------
/* simple connection */
$host = 'server:1433';
$user = 'username';
$pass = 'password';

$dblink = mssql_connect($host, $user, $pass);

This fails when the 'textsize' or 'textlimit' values are changed from defaults.

Expected result:
----------------
Expect a connection to the database server to be made.

Actual result:
--------------
Connection to database server fails.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-29 14:47 UTC] jason at burfield dot com
This latest cvs seems to have helped. PHP now seems to be reading the textsize value from the freetds.conf file as expected, however, I am still running in to problems passing large queries through to SQL Server. (2000)

Thanks for the quick update.
 [2004-01-30 11:13 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

User reports that the problem has been fixed. 
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 10:05:45 2022 UTC