php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #27002 Php doesn't compile Curl version stated in the configuration parameters
Submitted: 2004-01-21 19:09 UTC Modified: 2004-01-21 19:17 UTC
From: kayra at efashionconsulting dot com Assigned:
Status: Not a bug Package: cURL related
PHP Version: 4.3.4 OS: redhat 7.2
Private report: No CVE-ID: None
 [2004-01-21 19:09 UTC] kayra at efashionconsulting dot com
Description:
------------
I'm trying to compile Php+Curl on our production environment without disturbing actual Apache server, so I've installed Curl 7.10.8 (libcurl/7.10.8 + OpenSSL/0.9.7c + zlib/1.1.4) onto '/opt' directory. When I configure Php 4.3.4 with :

./configure --with-apxs=/webservices/bin/apxs\
        --with-curl=/opt\
        --with-curlwrappers\

it shows following lines in configuration output :

...
checking for cURL 7.9.8 or greater... libcurl 7.10.8
checking for curl_easy_perform in -lcurl... yes
checking for curl_version_info in -lcurl... yes
...

Which is fine since I want to compile Php with Curl 7.10.8. When I compile Php with 'make' it compiles it with the Curl version 7.10.3 (libcurl/7.10.3 OpenSSL/0.9.6b zlib/1.1.3).

I've compiled Php with the above settings several times and I did 'make clean' each time and deleted 'config.cache' and even tried to extract Php to some other directory but it doesn't work. I've installed same versions of the Php+Curl+Zlib ... to other server that doesn't have production site running, it generated same problem. I've installed Curl into its default '/usr/local/' directory and then Php noticed Curl 7.10.8.






Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-21 19:17 UTC] sniper@php.net
You have the old version somewhere in the libpath where it's found first. Make sure your /etc/ld.so.conf has /opt/lib as first entry.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 06:01:35 2019 UTC