php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26964 htmlentities and html_entity_decode, left&right single quotation mark issues
Submitted: 2004-01-19 07:21 UTC Modified: 2004-01-29 19:56 UTC
From: paj at pearfr dot org Assigned: moriyoshi (profile)
Status: Not a bug Package: Strings related
PHP Version: 5CVS, 4CVS OS: *
Private report: No CVE-ID: None
 [2004-01-19 07:21 UTC] paj at pearfr dot org
Description:
------------
Left and right single quotation (’ and ‘) are not converted correctly (or not recognized). Encode and decode fails.

Reproduce code:
---------------
$str = "Guide de l?utilisateur";
echo htmlentities($str);


Expected result:
----------------
Guide de l’utilisateur

Actual result:
--------------
Guide de l´utilisateur

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-20 16:10 UTC] moriyoshi@php.net
This's most likely due to my error.
Assigning it to me.


 [2004-01-29 19:56 UTC] moriyoshi@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

You must specify the name of the code set in which the 
string is represented when you are passing strings 
encoded in an encoding other than ISO-8859-1.

echo htmlentities($str, 0, "UTF-8");


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Dec 12 05:01:24 2019 UTC