php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26885 When using CLI interface fsockopen fails after several sucessfull attempts
Submitted: 2004-01-12 09:10 UTC Modified: 2004-01-20 05:03 UTC
From: gholyoak at courtdean dot com Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4CVS-2004-01-12 OS: w2k
Private report: No CVE-ID: None
 [2004-01-12 09:10 UTC] gholyoak at courtdean dot com
Description:
------------
I have a .cmd file scheduled to run every 30 mins in format:

c:\php\cli\php.exe batch_file.php

that downloads information from another site using fsockopen().

The scripts runs sucessfully for approximately 4 times then although fsockopen is sucessful, no data is returned.

But I can run the scripts interactively through the web-site interface as many times as I wish.

The script will not work again until I re-boot ?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-12 10:02 UTC] sniper@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc.

If possible, make the script source available online and provide
an URL to it here. Try avoid embedding huge scripts into the report.


 [2004-01-12 12:13 UTC] gholyoak at courtdean dot com
I've created a vastly cut-down version of the script :-

<?php

$headers = "GET /stats/eurofxref/eurofxref-daily.xml HTTP/1.0\r\nUser-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)\r\nHost: www.ecb.int\r\nAccept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, */*\r\n\r\n";

$URI_PARTS = parse_url('http://www.ecb.int/');

$fp = @fsockopen($URI_PARTS['host'],80,$errno,$errstr,10);

if (!$fp){echo 'Cannot open socket';return;}

fwrite($fp,$headers,strlen($headers));
$results = '';
do {
	$_data = fread($fp, 500000);
	if (strlen($_data) == 0) {
		break;
	}
	$results .= $_data;
} while(true);

fclose($fp);

Mail('gholyoak@courtdean.com','Data Retrieval results',$results);


echo strlen($results);

return;

?>


Dont forget to change the email address !!

To replicate the problem:

1. create a w2k .cmd file to call this script
2. Run the .cmd file as many time as you wish and you should get back an XML doc.
3. create a scheduled task using the .cmd file and run it several times.

You should notice that it works to start with and then fails but you can still run the .cmd file interactively ?

Curious ??
 [2004-01-13 05:09 UTC] sniper@php.net
I couldn't reproduce the bug with your code.

Hint: This one-liner works fine too:

$xml=file_get_contents("http://www.ecb.int/stats/eurofxref/eurofxref-daily.xml");

(no need for any fsockopen() stuff at all :)

 [2004-01-14 05:12 UTC] gholyoak at courtdean dot com
I cannot understand why it works several times then fails.

It works fine on our DEV server which is behind a proxy server, but fails on the LIV server that has no proxy but has a firewall (Ive turned the firewall off, but still no joy).

There are no entries in the Event viewer to indicate any problem.

Im at a loss but will keep trying and let you know if I come up with something.
 [2004-01-19 12:21 UTC] nlopess@php.net
Try to use HTTP/1.1, because I think there is no 'Host' in HTTP 1.0.

Maybe the proxy corrects the headers...
 [2004-01-20 04:42 UTC] gholyoak at courtdean dot com
Thanks for that.

I've already tried http/1.1 but as Im trying to emulate a browser, 1.1 has too many extra's that I dont want to code for.

I have been investigating this further and it seems to be an issue with the firewall.

It would appear that the interactive web version, i.e from IIS is identified to the firewall as originating from a local IP address (e.g. localhost or 127.0.0.1) but the CLI version via a batch job is identified to the firewall as the physical external IP address.

Im still puzzled as to why it started to work after a reboot and then fail but Im guessing this is a firewall issue.

I will close this report now but thank you for all your assistance to this point.
 [2004-01-20 05:03 UTC] wez@php.net
Not a PHP Bug.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jun 03 16:01:26 2020 UTC