php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2684 the gd include is not written correctly
Submitted: 1999-11-08 08:02 UTC Modified: 1999-11-08 10:20 UTC
From: iolalla at nmp dot es Assigned:
Status: Closed Package: Compile Failure
PHP Version: 3.0.12 OS: LINUX-REDHAT 5.2 -KERNEL 2.2.10
Private report: No CVE-ID: None
 [1999-11-08 08:02 UTC] iolalla at nmp dot es
when you try to compile it doesnt work and gives a message like this: 

gcc -g -O2 -O2   -I. -I.   -I/usr/local/home/apache_1.3.9/src/include -I/usr/local/home/apache_1.3.9/src/os/unix                  -I/usr/include -I/usr/local/mysql/include/mysql    -c functions/gd.c -o functions/gd.o
functions/gd.c:62: gd.h: No such file or directory
functions/gd.c:63: gdfontt.h: No such file or directory
functions/gd.c:64: gdfonts.h: No such file or directory
functions/gd.c:65: gdfontmb.h: No such file or directory
functions/gd.c:66: gdfontl.h: No such file or directory
functions/gd.c:67: gdfontg.h: No such file or directory
make: *** [functions/gd.o] Error 1

The problem is that the include is like this 
include <gd.h>
And should be like this in REDHAT 5.2 systems
include <gd/gd.h>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-11-08 10:20 UTC] markonen at cvs dot php dot net
The configure script allows you to specify the directory in which the gd headers files reside. (for example, ./configure --with-gd=/usr/local/include/gd)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Jun 14 06:01:22 2021 UTC