php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2678 Problem with include_path
Submitted: 1999-11-07 18:04 UTC Modified: 2002-06-16 14:19 UTC
From: autodata at execpc dot com Assigned:
Status: Not a bug Package: Other
PHP Version: 3.0.11 OS: Win NT Workstation
Private report: No CVE-ID: None
 [1999-11-07 18:04 UTC] autodata at execpc dot com
Problem with include_path

Platform: Windows NT Workstation
Webserver: Apache Win32 1.3.9
Database: MySQL Win32 Ver 3.22.28

The include path in PHP3.INI is set to:
	include_path=".;c:\obm\phplib"

However, when including the line ...
	require("obmlib.inc");

... results in ...
	Fatal error: Failed opening required 'obmlib.inc' in d:\obm\obm.php3 on line 13

The file "obmlib.inc" is located in the directory c:\obm\phplib.

When I hard-code the path ...
	require("c:\obm\phplib\obmlib.inc");
...the script runs as intended.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 14:19 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Jul 17 14:01:29 2024 UTC