php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26745 "No input file specified." with doc_root set to a path prefix
Submitted: 2003-12-30 00:46 UTC Modified: 2004-01-25 00:01 UTC
Votes:4
Avg. Score:4.5 ± 0.9
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: cdragon at draconic dot com Assigned:
Status: No Feedback Package: IIS related
PHP Version: 5.0.0b3 OS: windows 2000
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-12-30 00:46 UTC] cdragon at draconic dot com
Description:
------------
I've been setting up a development server with the exact same configuration as a live server.  Instead of using php 4.3.x I decided to try 5b3.  I use the same php.ini file.

I have IIS set to host two web sites in the following two directories:
c:\inetpub\wwwroot\www.draconic.com
c:\inetpub\wwwroot\www.draconic.net

In php.ini, I have doc_root set to "c:\inetpub\wwwroot" so that files in either of these directories can be loaded.  Yet when I load any php page from either site I get the error "No input file specified".  I am using IIS 5 under win2k using the ISAPI version of php 5b3.

I found that by changing doc_root from "c:\inetpub\wwwroot" to "c:\inetpub\wwwroot\www.draconic.com", I can get the php pages to work reliably for the first web site.  However, this means I get the "No input file specified" error when I try to load pages from "c:\inetpub\wwwroot\www.draconic.net".

With doc_root set to "c:\inetpub\wwwroot" I get the "No input file specified" most of the time, but I found it would occasionally load the php page correctly (maybe that was a caching thing?), or even give me a memory access violation when I tried to use the "include(...)" statement!  I can't figure out what was different when it worked or when it access violationed, but something seems to be seriously broken with doc_root in php 5b3.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-01-18 23:04 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip


 [2004-01-25 00:01 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2004-02-24 23:40 UTC] gtakid617 at yahoo dot com
I had the same problem on PHP 4.3.x, but resolved it by simply commenting out the doc_root line.  This way, PHP isn't looking for files in just 1 directory, but any directory.  Hope that helps!
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 02:03:34 2021 UTC