php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26736 __autoload not invoked for parent classes
Submitted: 2003-12-28 21:06 UTC Modified: 2003-12-29 19:54 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jaanus at heeringson dot com Assigned: helly
Status: Closed Package: Class/Object related
PHP Version: 5.0.0b3 OS: *
Private report: No CVE-ID:
 [2003-12-28 21:06 UTC] jaanus at heeringson dot com
Description:
------------
Autoload is not invoked for missing parent class in object declaration. This worked with php5-beta2.

Reproduce code:
---------------
Child_class and Parent_class are in separate documents. Autoload function is working.


class Child_class extends Parent_class {
}

$class=new Child_class();

Expected result:
----------------
No errors, everything loads.

Actual result:
--------------
Fatal error: Class 'Parent_class' not found in [path to Child_class document] on line 2

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-29 07:34 UTC] helly@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 [2003-12-29 19:37 UTC] jaanus at heeringson dot com
This bug was NOT fixed in snap 200312291230, which was created after your comment.
 [2003-12-29 19:54 UTC] jaanus at heeringson dot com
Just checked with 200312300030, and bug seems to be fixed.

Thanks, and sorry about the whining...
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 24 02:02:10 2014 UTC