php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #26694 strtotime fails on 'Sun, 21 Dec 2003 20:38:33 +0000 GMT'
Submitted: 2003-12-22 12:46 UTC Modified: 2005-06-20 09:23 UTC
Votes:3
Avg. Score:3.7 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:1 (33.3%)
From: phpbug at thequod dot de Assigned: derick
Status: Closed Package: Feature/Change Request
PHP Version: 4.3.4 OS: Windows XP
Private report: No CVE-ID:
 [2003-12-22 12:46 UTC] phpbug at thequod dot de
Description:
------------
I use strtotime to decode the If-Modified-Since header and just noticed that Firebird puts and offset in front of the "GMT". I don't know if this is RFC conform, but it should be recognized by strtotime(), IMHO.

Reproduce code:
---------------
var_dump(strtotime('Sun, 21 Dec 2003 20:38:33 +0000 GMT'));

Expected result:
----------------
-1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-22 13:29 UTC] phpbug at thequod dot de
summary: it fails on
$d = gmdate("r") . ' GMT';
var_dump( strtotime($d) );
 [2003-12-22 16:52 UTC] eru@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

You can either define the timezone by +dddd or by the 3-char identifier of that timezone. Your format isn\'t defined by the syntax - for further readings see http://www.gnu.org/manual/tar-1.12/html_chapter/tar_7.html

 [2004-04-25 11:39 UTC] derick@php.net
That doesn't mean we can't support it :)
 [2004-08-05 00:21 UTC] joelgphp at gadgetwiz dot com
The "+0000 GMT" format is also used by the Blackberry email client[s]. I've opened a ticket with them to fix the problem; however, because the issue seems to keep coming up, it should be parsed by the strtotime function even if it is not technically compliant.
 [2005-06-20 09:23 UTC] derick@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Fixed for PHP 5.1.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 10:03:03 2014 UTC