php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26616 [chm] garbled keyword?@lists on chm file of Manual
Submitted: 2003-12-13 15:10 UTC Modified: 2008-12-04 21:09 UTC
Votes:20
Avg. Score:4.7 ± 0.7
Reproduced:18 of 18 (100.0%)
Same Version:4 (22.2%)
Same OS:17 (94.4%)
From: 3miyasuka at star dot odn dot ne dot jp Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: win32
Private report: No CVE-ID: None
 [2003-12-13 15:10 UTC] 3miyasuka at star dot odn dot ne dot jp
Description:
------------
I downloaded the WindowsHelp format PHP Manual (Japanese version)
from [http://jp.php.net/get/php_manual_ja.chm/from/jp2.php.net/mirror].
Every time I click on the "keyword" tab, a garbled keyword list is
displayed. Everything else including the table of contents and the
explanatory text display normally.
I've tried it on WindowsXPPro-SP1, Windows2000-ProSP1, and Windows98
and I had the same problem.
Could I please have your assistance in solving this problem.
Thank you.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-13 15:34 UTC] derick@php.net
It's not only a problem with the Japanese version, but with any language that uses different character set. For some reason I can not get it right... no clue how to get the Help Compiler to do this right.
 [2004-02-15 00:35 UTC] uq2yura at infoseek dot jp
This problem arises from the Japanese font name in "chm_settings.php" (in CVS at /phpdoc/chm) is written at "Shift JIS" code.
I think that it is necessary to write by UTF-8 of internal encoding.
Thank you.
 [2004-04-12 13:18 UTC] byoon_ml at zing dot bytechase dot cx
You can compile the manual for yourself, or see the following pages;
http://www.php.gr.jp/project/doc/
http://ns1.php.gr.jp/pipermail/php-doc/2004-March/000342.html
 [2004-04-30 18:56 UTC] byoon_ml at zing dot bytechase dot cx
This problem hasn't been fixed yet.
If it is difficult to solve this or make a correct file,
the maintainer should not make it downloadable because
the users who download it must be in trouble continually.
 [2008-01-19 14:20 UTC] twk at nonn-et-twk dot net
It seems that you need to change locale settings prior to run HTML Help Workshop.
With Japanese windows, I could create the Japanese chm file correctly.
Also, I could create the Korean chm file after the following setting change.

Control Panel > Regional and Language Options
In "Regional Options" tab, Set "Standards and Formats" to Korean
In Advanced tab, Set "Language for non-unicode programs" to Korean

I have no idea how you can change locale settings in the help generation process.
 [2008-12-04 21:09 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

The new files will be available in about an hour on all mirrors
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 05:01:26 2019 UTC