php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2648 Conflict with mod_cgi when compiling with Solid -> Apache will not start
Submitted: 1999-11-01 06:00 UTC Modified: 2002-06-16 14:16 UTC
From: gordon+php at vip dot fi Assigned:
Status: Not a bug Package: Solid related
PHP Version: 3.0.13 OS: Linux 2.2.12-20smp
Private report: No CVE-ID: None
 [1999-11-01 06:00 UTC] gordon+php at vip dot fi
When compiling PHP with Solid RDBMS support (--with-solid) and Apache with DSO support, the Apache module order affects whether Apache starts at all or not. By default, the PHP module gets installed as the last one on the list, thus crippling
Apache (1.3.9) totally, not allowing it even to start. Moving mod_php _above_ mod_cgi on the list lets Apache start up normally. The problem exists only when
compiling --with-solid, so there might be some very iffy interactions between mod_php, mod_cgi and the Solid libraries. I have submitted this as a non-serious bug to the Apache development team - the problem is not that big as it can be circumvented by placing mod_php _before_ mod_cgi on the module list, but I still think it could/should be fixed. It just might be that the problem is with the Solid libraries or Apache, but it also could be a problem with PHP. Thus the multiple bug reports to various development teams.

To reproduce:

Compile Apache (1.3.9) with --enable-module=all --enable-shared=max --enable-rule=SHARED_CORE --enable-rule=SHARED_CHAIN; Compile PHP with --with-apxs=<path to apxs> --with-solid=<path to Solid includes/libs>;
the PHP module gets installed as the last one on the module list by default - Apache
will not start at this point. Move mod_php _above_ mod_cgi on the module list and Apache will start nicely.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-11-28 12:27 UTC] kara at cvs dot php dot net
What is the exact error when trying to start apache?
 [1999-11-28 21:18 UTC] gordon+php at vip dot fi
Apache reports no errors, but nevertheless does not start.
 [2000-01-10 06:57 UTC] gordon+php at vip dot fi
The previous report on the module order was somewhat correct; it seems that
when the solid libraries are compiled into PHP memory gets trashed
somewhere at apache startup. I verified this by placing PHP as the first and
the last module on the LoadModule/AddModule list, and when PHP is the first
on the list, apache starts nicely (perhaps due to the fact that when the PHP
module corrupts memory the corrupted parts get overwritten with the other
modules... or something); when PHP is the last one, apache crashes with a
SIGSEGV but does not output anything (as it has forked already and has no
TTY to print to, I suppose). This could be a problem with the solid libraries
themselves and not with PHP, but there is something really fishy about this :)
A workaround is to place PHP as the first module on the list, but...
 [2002-06-16 14:16 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 22 02:01:23 2019 UTC