|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26467 flock does not force wouldblock argument to be passed by reference
Submitted: 2003-11-29 15:26 UTC Modified: 2003-11-29 15:52 UTC
From: mlemos at acm dot org Assigned:
Status: Closed Package: Filesystem function related
PHP Version: 4CVS-2003-11-29 (stable) OS:
Private report: No CVE-ID:
 [2003-11-29 15:26 UTC] mlemos at acm dot org
When present, the wouldblock argument should be a reference to a variable in which it will return whether it would block if attempted to lock the file in non-blocking mode.

However, since the argument is not forced to be a reference, it will only work if you pass an explicit reference to the argument, leading to the usual warnings.

Changing flock function entry in ext/standard/basic_functions.c like this fixes the problem:


Reproduce code:
	if(!($file=(fopen("testfile","w")))) die("could not open file");
		echo "could lock ",serialize($wouldblock),"\n";
		echo "failed lock\n";

Expected result:
could lock i:0;

Actual result:
could lock N;


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-29 15:52 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 21:01:34 2015 UTC