php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #26309 imageftbbox() requires the optional parameter
Submitted: 2003-11-19 01:02 UTC Modified: 2004-09-16 17:06 UTC
From: kputnam at putnamcabinets dot com Assigned: philip
Status: Closed Package: Documentation problem
PHP Version: 5.0.0b2 (beta2) OS: Debian GNU/Linux (Sid)
Private report: No CVE-ID:
 [2003-11-19 01:02 UTC] kputnam at putnamcabinets dot com
Description:
------------
The documentation shows that the last parameter is optional (extrainfo) but an error is generated when it is left out. Calling with an empty array as the last parameter resolves the issue.

Reproduce code:
---------------
$box = imageftbbox($size,$angle,$this->fonts[$font],$text);

Actual result:
--------------
PHP Warning:  Wrong parameter count for imageftbbox()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-19 10:48 UTC] iliaa@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

This is a documentation problem.
The imagettfbbox() allows the 
 [2004-07-15 01:32 UTC] philip@php.net
Reopening until an official word exists.  I assume it's not optional and people need to use array() for that but wonder if this requirement has been removed in PHP 5.  Regardless this is an existing doc problem.
 [2004-09-16 17:06 UTC] vrana@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

"Parameter extrainfo is optional since PHP 4.3.5."

BTW patch http://cvs.php.net/diff.php/php-src/ext/gd/gd.c?r1=1.279&r2=1.280&ty=u made superfluous optional parameter to imagettfbbox() and imagettftext().
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 08:02:55 2014 UTC