|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26253 TOKENIZER self-contained-extension: make fails
Submitted: 2003-11-14 10:14 UTC Modified: 2003-11-17 14:30 UTC
From: lantonenk at inbox dot ru Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4CVS-2003-11-14 (stable) OS: RedHat Linux 7.3 (with updates)
Private report: No CVE-ID:
 [2003-11-14 10:14 UTC] lantonenk at inbox dot ru
I try to make TOKENIZER self-contained-extension.
phpize, aclocal, ./configure works fine.
make fails (look at reproduce code) with message:
make: *** No rule to make target `Zend/zend_language_parser.h', needed by `tokenizer.lo'.  Stop.
I think the problem is in Makefil.frag. This file contains line:

$(builddir)/tokenizer.lo: Zend/zend_language_parser.h

When repeat all steps with empty Makefil.frag, make works fine, and I have

Reproduce code:
> cd ext/tokenizer
> phpize
> aclocal
> ./configure
> make
make: *** No rule to make target `Zend/zend_language_parser.h', needed by `tokenizer.lo'.  Stop.

Expected result:
> make
Libraries have been installed in:
Result - there is in ./modules

Actual result:
> make
make: *** No rule to make target `Zend/zend_language_parser.h', needed by `tokenizer.lo'.  Stop.
Result - there is no


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-17 14:30 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 00:01:32 2015 UTC