php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26184 unable to detect character encoding
Submitted: 2003-11-09 04:00 UTC Modified: 2003-11-17 20:05 UTC
From: tom at nooper dot com Assigned: moriyoshi (profile)
Status: Closed Package: mbstring related
PHP Version: 4.3.4 OS: Redhat 8
Private report: No CVE-ID: None
 [2003-11-09 04:00 UTC] tom at nooper dot com
Description:
------------
I get the following error generated:
   mb_convert_encoding(): Unable to detect character encoding

Up to 4.3.3 this works no problem. I compiled php with same options including the --enable-mbstring=all. If I look at phpinfo() output it seems that all the languages are missing no matter if I compile with --enable-mbstring=ja or other.

I noticed another bug which was closed that fixed a bug in the  reporting of phpinfo() for mbstring where it was suggested that all languages were included now from 4.3.4 independant of compile options.

The code snippet that was used to generate the error above is simply:

echo mb_convert_encoding($jText, 'SJIS','AUTO');

where $jText is some "EUC-JP" text.

I tried the latest php snapshot from cvs also and it also doesn't work. If you need a short example program to reproduce this problem, I can look into it from Monday/Tuesday.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-11 15:38 UTC] moriyoshi@php.net
Please try setting mbstring.language to the appropriate 
language name in your php.ini.

 [2003-11-17 18:19 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-11-17 20:05 UTC] tom at nooper dot com
Thanks guys... sorry for lack of feedback. I've not had time to test a new php build in dev yet since trying it last time. I'll reopen the bug if the suggested fix fails, but for now you can assume it works.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 04:05:53 2022 UTC