php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26098 Some characters omitted in a long message
Submitted: 2003-11-03 14:36 UTC Modified: 2003-11-03 19:05 UTC
From: sistekj at fel dot cvut dot cz Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.3 OS: Win XP Prof. CZ
Private report: No CVE-ID: None
 [2003-11-03 14:36 UTC] sistekj at fel dot cvut dot cz
Description:
------------
When sending a long plain-text message by mail(), single characters at specific positions are omitted. The interval between missing characters is about 810 characters. It is independent of text sent, formatting, line-ending commands or number of characters in one row.
PHP: 4.3.3 as a module of Apache 2.0.47, Win XP Prof. CZ,
Windows firewall OFF, standard SMTP server.

SMTP-related changes in php.ini:
SMTP = mailgw.cvut.cz
sendmail_from = sistekj@vc.cvut.cz

Reproduce code:
---------------
<?php
$long_row="Text to be repeated many times, any data, any contents, anything can be here. This sentence is to fill the space  \r\n ";

$message="";
for ($i = 1; $i <= 80; $i++) {
    $message=$message.$long_row; //very looong message body
}
mail("sistekj@vc.cvut.cz", "Test message", $message, "From: sistekj@vc.cvut.cz");
?>

Expected result:
----------------
$long_row repeated 80 times.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-03 19:05 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

If you had bothered to search the bug database before submitting this report, you would have found quite a lot
reports..and that this is also fixed already in CVS.
(fix is going to be in PHP 4.3.4, which will be released today/tomorrow)

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 02:05:56 2022 UTC