php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #26092 header location utf-8
Submitted: 2003-11-03 04:32 UTC Modified: 2003-11-03 04:38 UTC
From: a_s at seznam dot cz Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.3.2 OS: WinXP,Win2003Server-Web
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: a_s at seznam dot cz
New email:
PHP Version: OS:

 

 [2003-11-03 04:32 UTC] a_s at seznam dot cz
Description:
------------
PHP 4.3.2.2 CGI

Try to save the code below to file in utf-8.

Reproduce code:
---------------
<?//!!!redirect has to be in ansi and not in UTF-8 !!!!
if (!headers_sent($filename, $linenum)) {
    header ('Location: http://www.google.com/');
    exit;

// You would most likely trigger an error here.
} else {

    print "Headers already sent in $filename on line $linenum\nCannot redirect.";
    exit;
}
?>

Expected result:
----------------
Redirect to google

Actual result:
--------------
message:

Headers already sent in C:\...\redir_.php on line 1 Cannot redirect.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-03 04:38 UTC] moriyoshi@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

dupe of bug #22108

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 19:03:38 2021 UTC