php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25944 memory limit reached in PEAR_Error constructor
Submitted: 2003-10-22 01:57 UTC Modified: 2004-09-01 16:13 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: rashid at ds dot pg dot gda dot pl Assigned:
Status: Not a bug Package: PEAR related
PHP Version: 4.3.2 OS: linux
Private report: No CVE-ID: None
 [2003-10-22 01:57 UTC] rashid at ds dot pg dot gda dot pl
Description:
------------
in applications that use DB_DataObject and do a lot of queries memory limit is reached in PEAR_Error constructor. the reason is big number of calls to debug_backtrace.

the best solution might be disabling call to debug_backtrace by default and adding option to turn it back on.

this bug has been discussed here:
<20031021102601.99579.qmail@pb1.pair.com>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-01 16:13 UTC] alan_k@php.net
can you report this on pear.php.net - none of the pear maintainers read bugs.php.net (package PEAR bug)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 21 16:01:27 2020 UTC