php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25893 go-pear.bat and Go-pear.php failed
Submitted: 2003-10-17 05:11 UTC Modified: 2004-01-26 04:30 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: uwe dot heuer at t-online dot de Assigned: pajoye (profile)
Status: Not a bug Package: PEAR related
PHP Version: 4.3.4RC1 OS: Windows XP
Private report: No CVE-ID: None
 [2003-10-17 05:11 UTC] uwe dot heuer at t-online dot de
Description:
------------
I tried to install the PEAR packages either by the go-pear.bat script via command shell (4.3.4RC2-dev). The batch comes up with the following error:
Loading zlib: ok
Using local package: PEAR ..... ok
....
Downloading package: phpUnit ..... download of http://pear.php.net/get/phpUnit failed: Der Vorgang wurde erfolgreich beendet. (0) Press a button ...
(it's a german XP installation).

The PHP-Script started via browser (http://localhost/go-pear.php) comes up with the error:

Warning: opendir(C:\WINDOWS\temp/gop15.tmp): failed to open dir: Invalid argument in C:\Programme\Apache Group\Apache\htdocs\go-pear.php on line 1064

Warning: readdir(): supplied argument is not a valid Directory resource in C:\Programme\Apache Group\Apache\htdocs\go-pear.php on line 1065

Warning: closedir(): supplied argument is not a valid Directory resource in C:\Programme\Apache Group\Apache\htdocs\go-pear.php on line 1076

Warning: rmdir(C:\WINDOWS\temp/gop15.tmp): no such file or directory in C:\Programme\Apache Group\Apache\htdocs\go-pear.php on line 1077

and the process stops!!!




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-18 12:44 UTC] sfox@php.net
Hi,

Sorry, but I can't reproduce this.

The first attempt sounds like a broken connection (can you replicate it, at the same point every time?) and the second could be a permissions issue.  Please can you upgrade PHP from http://snaps.php.net and try again, and if you still have problems - it would be useful to know which server you're using :)
 [2003-10-18 12:45 UTC] sfox@php.net
Setting to feedback.
 [2003-10-22 05:09 UTC] uwe dot heuer at t-online dot de
I can't try to reproduce the error before 4 weeks because I'm on vacation now and I used my desktop at work. If still interested I will use the latest snapshot and try it again. Then I will tell the server I'm using.
 [2004-01-24 09:25 UTC] sfox@php.net
Are you still experiencing this problem with recent PHP 4.3?

Please reply either way so that we know whether to close this bug report!
 [2004-01-26 04:20 UTC] uwe dot heuer at t-online dot de
Hello, 
I'm sorry, but the configuration of my laptop changed totally, so i cannot reproduce the error :-(
 [2004-01-26 04:30 UTC] pajoye@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Feb 23 17:01:28 2020 UTC