php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25880 file_exists() strange behaviour
Submitted: 2003-10-15 09:22 UTC Modified: 2003-10-16 00:52 UTC
From: mpilipenko at ukr dot net Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 4.3.3 OS: Windows 2000 Pro +SP4
Private report: No CVE-ID: None
 [2003-10-15 09:22 UTC] mpilipenko at ukr dot net
Description:
------------
Function file_exists() returns TRUE on non-existing files.
Tested on Windows 2000 Pro +SP4, Apache 1.3.27 & PHP 4.3.1, 4.3.3, 4.3.4RC1

Reproduce code:
---------------
<?
var_dump(file_exists("con"));
var_dump(file_exists("con.[anything_you_want]"));
?>

Expected result:
----------------
false
false

Actual result:
--------------
true
true

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-16 00:52 UTC] sniper@php.net
Actually, not 'fixed'. "con" is special file in Windows (since DOS, iirc..)

It would be strange if it didn't exist.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 23:04:05 2022 UTC