php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25724 register_long_arrays breaks superglobals
Submitted: 2003-10-02 04:55 UTC Modified: 2004-03-18 09:00 UTC
Votes:3
Avg. Score:3.3 ± 1.2
Reproduced:2 of 3 (66.7%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: kauer at face-online dot de Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 5CVS-2004-03-15 OS: *
Private report: No CVE-ID:
 [2003-10-02 04:55 UTC] kauer at face-online dot de
Description:
------------
Using the binary from snaps.php.net, turning register_long_arrays off in .htaccess will make $_SERVER unavailable.

Reproduce code:
---------------
File: .htaccess
php_flag register_long_arrays off

PHP:
var_dump($_SERVER);

Expected result:
----------------
I expect to see a variable dump of $_SERVER.

Actual result:
--------------
var_dump outputs NULL

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-11-28 21:20 UTC] sniper@php.net
Reproducable with this quick'n'dirty way too:

# sapi/cli/php -d'register_long_arrays=off' -r 'var_dump($_SERVER);'


 [2004-01-21 02:03 UTC] sniper@php.net
Only these superglobals are broken:

$_SERVER
$_ENV
$_REQUEST

All other work fine..


 [2004-01-21 02:05 UTC] sniper@php.net
And both register_globals and register_long_arrays have to be off to reproduce this!

 [2004-01-27 13:21 UTC] danielc at analysisandsolutions dot com
Bug 26206 -- http://bugs.php.net/bug.php?id=26206 -- has been marked as a duplicate of this one.
 [2004-03-18 09:00 UTC] zeev@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 01:01:56 2014 UTC