php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25721 wrong MySQL server version info after upgrade from 3.23.57 to 4.0.15
Submitted: 2003-10-01 15:57 UTC Modified: 2003-10-06 05:14 UTC
From: ergin at ergin dot net Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.3.3 OS: Linux - e-smith RedHat 7.3 based
Private report: No CVE-ID: None
 [2003-10-01 15:57 UTC] ergin at ergin dot net
Description:
------------
phpinfo() shows old mysql version

I've recntly upgraded from RHs 3.23.57 RPMs to MySQL's 4.0.15 RPMs.

When running phpinfo() it still shows the older version.
MySQL Support enabled 
Active Persistent Links  0  
Active Links  1  
Client API version  3.23.57  
MYSQL_MODULE_TYPE  external  
MYSQL_SOCKET  /var/lib/mysql/mysql.sock  
MYSQL_INCLUDE  -I/usr/include/mysql  
MYSQL_LIBS  -L/usr/lib/mysql -lmysqlclient  



../phpmyadmin/index.php shows the correct version. (lang-swe)
V?lkommen till phpMyAdmin 2.5.3
MySQL 4.0.15-standard k?rs p? localhost som root@localhost




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-10-01 17:28 UTC] pollita@php.net
Did you recompile PHP after upgrading MySQL (linking against the new client libraries rather than the bundled client libraries)? (or install a new RPM which uses a PHP which links against MySQL 4 client libraries)?

Most likely not.  phpMyAdmin is probably reporting the MySQL SERVER version which is not necessarily the same as the MySQL CLIENT version.  (MySQL 3.x clients are compatable with MySQL server versions prior to 4.1).  Therefore it would be correct that PHP still reports a CLIENT version of 3.23.57 while the PHP script "phpMyAdmin" would get a response of "4.0.15" from the mysql SERVER.
 [2003-10-01 20:46 UTC] sniper@php.net
Recompile PHP. You propably have static build/only static mysql libs there.

 [2003-10-06 05:14 UTC] ergin at ergin dot net
Here are mysql related RPMs on my system


[root@erginsme01 root]# rpm -qa|grep mysql
php-mysql-4.3.3-1db
libdbi-dbd-mysql-0.6.4-2
e-smith-mysql-1.10.0-01
snort-mysql-1.9.0-1snort

[root@erginsme01 root]# rpm -qa|grep MySQL
MySQL-shared-compat-4.0.15-0
perl-DBD-MySQL-1.2219-6
MySQL-client-4.0.15-0
MySQL-server-4.0.15-0
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 04:05:53 2022 UTC