php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25648 XSLT xslt_set_encoding() being detected as incorrectly missing
Submitted: 2003-09-24 14:59 UTC Modified: 2005-01-16 01:00 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:2 (100.0%)
From: mloftis at wgops dot com Assigned:
Status: No Feedback Package: XSLT related
PHP Version: 4.3.10 OS: Linux 2.4
Private report: No CVE-ID:
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-09-24 14:59 UTC] mloftis at wgops dot com
Description:
------------
As per my comment on #24786.  23148, 21427, 20640 may all also be related.

This is with the current version.

The issue is this, the -ljs and other libs tested earlier by the
config.m4 file ARE NOT used during the calls to check teh Sablot libs
for SetEncoding and GetOptions calls.  Thsi bug STILL exists in 4.3.3
and is the reason why (on my system at atleast) they don't get compiled
in unless i manually hit main/php_config.h with vi and change the undef
to #define.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-24 18:53 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 [2004-04-16 20:21 UTC] gbaratto at superb dot net
This is still a problem on php-4.3.5

As mloftis, I had to change main/php_config.h, setting these:
#define HAVE_SABLOT_SET_ENCODING
#define HAVE_SABLOT_GET_OPTIONS
 [2004-12-21 19:34 UTC] mloftis at wgops dot com
Still present in 4.3.10.
 [2005-01-08 13:34 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2005-01-16 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 09:02:28 2014 UTC