php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #25599 Documentation-Error in CHM-File for Function number_format()
Submitted: 2003-09-19 03:00 UTC Modified: 2004-02-17 12:06 UTC
From: thom dot haas at gmx dot de Assigned:
Status: Not a bug Package: Documentation problem
PHP Version: 4.3.2 OS: WXP
Private report: No CVE-ID: None
 [2003-09-19 03:00 UTC] thom dot haas at gmx dot de
Description:
------------
Today (2003-09-19) I've downloaded the latest documentation-file (*.chm) in German. 
Because I didn't use it for a long time I had to find out the syntax for number_format(). In this file it's not written correctly. But in the online-manual it's quite correct. It's not a huge bug, but you might fix it.

AND, I really expect huge differences between both docu-versions (have a look at the numbering).

Reproduce code:
---------------
*.chm:
string number_format ( float number [, int decimals [, string dec_point [, string thousands_sep]]])

online-manu:
string number_format ( float number [, int decimals])

string number_format ( float number, int decimals, string dec_point, string thousands_sep)



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-12-02 10:45 UTC] nunoplopes at sapo dot pt
This funtion isn't yet translated to german.

The problem is that the chm version is very old...
 [2004-02-17 12:06 UTC] nlopess@php.net
PHP manual is huge and takes long to compile. The German CHM is _very_ old and the proto was fixed after the manual building.
This change will reflect in the next manual build.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 15:03:36 2021 UTC