php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25596 PEAR::XML::Transformer - PHPdocumentor patch
Submitted: 2003-09-18 15:09 UTC Modified: 2004-03-14 02:40 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: junk at steti dot com Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.3 OS: ALL
Private report: No CVE-ID: None
 [2003-09-18 15:09 UTC] junk at steti dot com
Description:
------------
The PEAR module XML::Transformer version 0.8.2, has invalid tags that cause PHPdocumentor to fail.  This fix is on line 203, as it contains a @param tag with no datatype/or description.

Either removing the line, or setting it to '@param NULL' will fix this issue.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-03-13 15:38 UTC] helgi at trance dot is
Here's the diff for that ;)
The line nr has of coz changed because there is more recent version of this pacagke then when this was reported :)
But sadly this very very very litle indeed bug hasn't been fixed ;/

--- Transformer.php     2004-03-13 19:38:39.000000000 +0000
+++ Transform_Changed.php       2004-03-13 19:40:45.000000000 +0000
@@ -371,7 +371,7 @@
     /**
     * Returns a stack dump as a debugging aid.
     *
-    * @param
+    * @param NULL
     * @return string
     * @access public
     */
 [2004-03-14 02:40 UTC] sebastian@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Aug 05 02:01:23 2021 UTC