php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25463 ClibPDF Does Not Compile With Bundled GD
Submitted: 2003-09-09 22:52 UTC Modified: 2003-09-11 11:25 UTC
From: nathan@php.net Assigned:
Status: Closed Package: ClibPDF related
PHP Version: 4.3.3 OS: Linux 2.4
Private report: No CVE-ID:
 [2003-09-09 22:52 UTC] nathan@php.net
Description:
------------
When installing with --with-clibpdf, if using the Bundled GD (4.3.2 and 4.3.3), the compile will fail. Compiling GD on its own, and using --with-gd=/usr/local/gd2 and then compiling with ClibPDF works fine.

Reproduce code:
---------------
./configure --prefix=/usr/local/php --with-apxs=/usr/local/apache/bin/apxs --with-mysql --enable-cli --disable-cgi --with-zlib --with-bz2 --enable-calendar --enable-exif --enable-ftp --with-gd=/usr/local/gd2 --with-jpeg-dir=/usr/local/libjpeg --with-freetype-dir=/usr/local/freetype2 --with-iconv --enable-sockets --with-curl=/usr --with-mcrypt=/usr --with-cpdflib

Expected result:
----------------
Build fine.

Actual result:
--------------
Do not have exact error. Relates to no such file or directory gd.h, expecting to find the version in dir --with-gd=x, doesnt know where to find bundled version.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-09 23:58 UTC] sniper@php.net
Works just fine for me. (as usual)

And is it now with --with-gd=somepath or --with-gd ????
Your 'reproduce code' shows that you used external GD?
So with which does the 'not compile' happen?
And I really, REALLY need to know WHAT doesn't work.
Do you get some error? Or what?

FYI: I do expect a little bit better bug reports from people who's email address contains @php.net...

 [2003-09-10 23:52 UTC] nathan@php.net
Ok. --with-gd does not compile, the error is related to cannot find gd.h from within cpdf.c

--with-gd=somepath does work, using external GD.

I dont have a test machine i can reproduce it on now...since its a production server I was installing on, now that its on there.
 [2003-09-11 00:00 UTC] nathan@php.net
Ok, got lucky. Reproduced it for you :)

/home/src/php-4.3.3/ext/cpdf/cpdf.c:41:16 gd.h: No such file or directory
/home/src/php-4.3.3/ext/cpdf/cpdf.c: In function 'zif_cpdf_place_inline_image':
/home/src/php-4.3.3/ext/cpdf/cpdf.c:2481: `gdImagePtr' undeclared (first use in this function)
/home/src/php-4.3.3/ext/cpdf/cpdf.c:2481: (Each undeclared identifier is reported only once
/home/src/php-4.3.3/ext/cpdf/cpdf.c:2481: for each function it appears in.)
/home/src/php-4.3.3/ext/cpdf/cpdf.c:2481: syntax error before "im"
/home/src/php-4.3.3/ext/cpdf/cpdf.c:2505: `im' undeclared (first use in this function)
make: *** [ext/cpdf/cpdf.lo] Error 1
 [2003-09-11 11:25 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 09:02:28 2014 UTC