php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25420 pg_connect using connectstring only connect with default database
Submitted: 2003-09-07 18:55 UTC Modified: 2003-09-07 19:11 UTC
From: domingo at dad-it dot com Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 4.3.3 OS: Linux SUSE 7.3
Private report: No CVE-ID: None
 [2003-09-07 18:55 UTC] domingo at dad-it dot com
Description:
------------
pg_connect using connectstring only connect with default database, for some reason php calls PQconnect() with a blank string and with that only default database connexion is made.

Reproduce code:
---------------
Any attempt to connect using connectstring to other database tha default.

Expected result:
----------------
Connect to specified database

Actual result:
--------------
Only connect to default database.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-07 19:00 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

*SIGH* bug #25415
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 09:01:31 2024 UTC